aboutsummaryrefslogtreecommitdiffstats
path: root/packages/psplash
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-12-02 15:10:07 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-12-02 15:10:07 +0000
commitee7463f37faab09ec5fdb47ab549143167b32a25 (patch)
treec157a57601f3d0214e821d55a3ec908899bfa5a0 /packages/psplash
parentc16872e4a022d395cbb9282597a5c13a1ca11321 (diff)
downloadopenembedded-ee7463f37faab09ec5fdb47ab549143167b32a25.tar.gz
psplash svn: Add patch to do proper logo display height calc.
* So, psplash uses bottom 1/6 of screen for progress bar. So, teach it to use 5/6 of the screen height for logo placement, not the whole height, which leads to overlap of logo and bar.
Diffstat (limited to 'packages/psplash')
-rw-r--r--packages/psplash/files/logo-math.patch13
-rw-r--r--packages/psplash/psplash_svn.bb4
2 files changed, 16 insertions, 1 deletions
diff --git a/packages/psplash/files/logo-math.patch b/packages/psplash/files/logo-math.patch
new file mode 100644
index 0000000000..87574b1855
--- /dev/null
+++ b/packages/psplash/files/logo-math.patch
@@ -0,0 +1,13 @@
+Do better math when showing logo vs progressbar.
+
+--- psplash/psplash.c.org 2007-09-22 20:33:36.000000000 +0300
++++ psplash/psplash.c 2007-12-01 21:27:08.000000000 +0200
+@@ -258,7 +258,7 @@
+ /* Draw the OH logo */
+ psplash_fb_draw_image (fb,
+ (fb->width - HAND_IMG_WIDTH)/2,
+- (fb->height - HAND_IMG_HEIGHT)/2,
++ ((fb->height * 5) / 6 - HAND_IMG_HEIGHT)/2,
+ HAND_IMG_WIDTH,
+ HAND_IMG_HEIGHT,
+ HAND_IMG_BYTES_PER_PIXEL,
diff --git a/packages/psplash/psplash_svn.bb b/packages/psplash/psplash_svn.bb
index 98e2a36805..398141de69 100644
--- a/packages/psplash/psplash_svn.bb
+++ b/packages/psplash/psplash_svn.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://projects.o-hand.com/psplash"
SECTION = "base"
LICENSE = "GPL"
PV = "0.0+svnr${SRCREV}"
-PR = "r9"
+PR = "r10"
# You can create your own pslash-hand-img.h by doing
# ./make-image-header.sh <file>.png HAND
@@ -17,6 +17,8 @@ SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
file://psplash-init"
S = "${WORKDIR}/psplash"
+# This really should be default, but due yo openmoko hack below, can't be easily
+SRC_URI_append_angstrom = " file://logo-math.patch;patch=1 "
SRC_URI_append_openmoko = " file://configurability.patch;patch=1 "
inherit autotools pkgconfig update-rc.d