aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pulseaudio
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-09-28 17:30:02 +0000
committerKoen Kooi <koen@openembedded.org>2008-09-28 17:30:02 +0000
commit171bc5c067cefe8ece060ae11506133df9ed64ae (patch)
treedca753e356aa68faf6e64d69257e7431decb2163 /packages/pulseaudio
parent98fee68c313537aeaf56617cf49cf67a10f1b8c5 (diff)
downloadopenembedded-171bc5c067cefe8ece060ae11506133df9ed64ae.tar.gz
pulseaudio meta: fix samplerate regression, make it machine specific
* this seems to be the 4th package in OE to install a /etc/asound.conf, so it probably can't be installed since alsa itself already provides that file...
Diffstat (limited to 'packages/pulseaudio')
-rwxr-xr-xpackages/pulseaudio/pulseaudio-meta/pulseaudio2
-rw-r--r--packages/pulseaudio/pulseaudio-meta_0.9.10.bb14
2 files changed, 13 insertions, 3 deletions
diff --git a/packages/pulseaudio/pulseaudio-meta/pulseaudio b/packages/pulseaudio/pulseaudio-meta/pulseaudio
index 964947376e..e0d33bd2b9 100755
--- a/packages/pulseaudio/pulseaudio-meta/pulseaudio
+++ b/packages/pulseaudio/pulseaudio-meta/pulseaudio
@@ -15,7 +15,7 @@ prog="pulseaudio"
start() {
echo -n "Starting audio server: "
# FIXME once alsa/shm permissions have been fixed, supply --system
- start-stop-daemon -S -x /usr/bin/pulseaudio -- --no-cpu-limit --resample-method=trivial -D -nF /etc/pulse/session
+ start-stop-daemon -S -x /usr/bin/pulseaudio -- --no-cpu-limit --resample-method=sinc-fastest -D -nF /etc/pulse/session
if [ $? = 0 ]; then
echo "$prog (warning ignores)." # FIXME remove comment on warning
diff --git a/packages/pulseaudio/pulseaudio-meta_0.9.10.bb b/packages/pulseaudio/pulseaudio-meta_0.9.10.bb
index 0f1dd6a5b6..b11963b869 100644
--- a/packages/pulseaudio/pulseaudio-meta_0.9.10.bb
+++ b/packages/pulseaudio/pulseaudio-meta_0.9.10.bb
@@ -5,19 +5,24 @@ RDEPENDS = "\
pulseaudio-module-alsa-sink \
pulseaudio-module-alsa-source \
pulseaudio-module-cli \
+ pulseaudio-module-default-device-restore \
+ pulseaudio-module-detect\
pulseaudio-module-esound-protocol-unix \
pulseaudio-module-simple-protocol-tcp \
pulseaudio-module-native-protocol-unix \
pulseaudio-module-cli-protocol-unix \
+ pulseaudio-module-rescue-streams\
pulseaudio-module-suspend-on-idle \
+ pulseaudio-module-volue-restore \
gst-plugin-pulse \
libasound-module-ctl-pulse \
libasound-module-pcm-pulse \
"
-PR = "r1"
+PR = "r2"
inherit update-rc.d
+export TARGET_PFPU = "${TARGET_FPU}"
INITSCRIPT_NAME = "pulseaudio"
INITSCRIPT_PARAMS = "defaults 35"
@@ -34,11 +39,16 @@ do_install() {
install -d ${D}/${sysconfdir}/pulse
install -m 0755 ${WORKDIR}/session ${D}/${sysconfdir}/pulse/session
install -m 0644 ${WORKDIR}/asound.conf ${D}/${sysconfdir}
+
+ if [ "x${TARGET_PFPU}" == "xsoft" ] ; then
+ sed -i -e s:resample-method=sinc-fastest:resample-method=trivial: ${D}${sysconfdir}/init.d/pulseaudio
+ fi
}
-PACKAGE_ARCH = "all"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
CONFFILES_${PN} = "\
+ ${sysconfdir}/init.d/pulseaudio \
${sysconfdir}/pulse/session \
${sysconfdir}/asound.conf \
"