aboutsummaryrefslogtreecommitdiffstats
path: root/packages/puzz-le
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/puzz-le
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/puzz-le')
-rw-r--r--packages/puzz-le/.mtn2git_empty0
-rw-r--r--packages/puzz-le/puzz-le-2.0.0/.mtn2git_empty0
-rw-r--r--packages/puzz-le/puzz-le-2.0.0/gcc3.patch24
-rw-r--r--packages/puzz-le/puzz-le_2.0.0.bb17
4 files changed, 41 insertions, 0 deletions
diff --git a/packages/puzz-le/.mtn2git_empty b/packages/puzz-le/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/puzz-le/.mtn2git_empty
diff --git a/packages/puzz-le/puzz-le-2.0.0/.mtn2git_empty b/packages/puzz-le/puzz-le-2.0.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/puzz-le/puzz-le-2.0.0/.mtn2git_empty
diff --git a/packages/puzz-le/puzz-le-2.0.0/gcc3.patch b/packages/puzz-le/puzz-le-2.0.0/gcc3.patch
index e69de29bb2..9435dc5c95 100644
--- a/packages/puzz-le/puzz-le-2.0.0/gcc3.patch
+++ b/packages/puzz-le/puzz-le-2.0.0/gcc3.patch
@@ -0,0 +1,24 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- puzzle_arm/OptionsDialog.cpp~gcc3 2002-07-16 04:01:12.000000000 +0200
++++ puzzle_arm/OptionsDialog.cpp 2004-02-19 21:10:32.000000000 +0100
+@@ -24,14 +24,14 @@
+
+ int OptionsDialog::sOptions[5]={60,50,40,30,20};
+
+-OptionsDialog::OptionsDialog(QString *currLevel,QString *th, bool *se,bool *ar,bool *tl, int *gs, QWidget *parent=0,const char *name=0):QDialog(parent,name,true,WStyle_Customize|WStyle_NoBorderEx )
++OptionsDialog::OptionsDialog(QString *currLevel,QString *th, bool *se,bool *ar,bool *tlx, int *gs, QWidget *parent,const char *name):QDialog(parent,name,true,WStyle_Customize|WStyle_NoBorderEx )
+ {
+ the=th;
+ ile=currLevel;
+ ise=se;
+ iar=ar;
+ igs=gs;
+- itl=tl;
++ itl=tlx;
+
+ QFont f=font();
+ f.setBold(true);
diff --git a/packages/puzz-le/puzz-le_2.0.0.bb b/packages/puzz-le/puzz-le_2.0.0.bb
index e69de29bb2..839f6f0edd 100644
--- a/packages/puzz-le/puzz-le_2.0.0.bb
+++ b/packages/puzz-le/puzz-le_2.0.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Puzz-le is a colorful arcade logic game for Qt/Embedded based Palmtop Environments."
+SECTION = "opie/games"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.warmi.net/zaurus/files/puzz-le_${PV}.tar.gz \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/puzzle_arm"
+
+inherit palmtop
+
+do_install() {
+ install -m 0755 puzz-le Qtopia/puzz-le/${palmtopdir}/bin/puzz-le
+ install -d ${D}/
+ cp -a Qtopia/puzz-le/* ${D}/
+}