aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-10-04 09:48:50 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-10-04 09:48:50 +0000
commit2c66cf2e9d662ba8941dd11741f8e825a6f475c1 (patch)
tree5699eafff92aa30aa447783c6ab66ecba45f7013 /packages/python
parent7cda59cb5b6d78f4d41cf233f9a7f48109042a2e (diff)
downloadopenembedded-2c66cf2e9d662ba8941dd11741f8e825a6f475c1.tar.gz
python: fixed manifest to NOT rdepend on libraries - shlibs code will do it in correct way
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-2.4.3-manifest.inc4
-rw-r--r--packages/python/python_2.4.3.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/packages/python/python-2.4.3-manifest.inc b/packages/python/python-2.4.3-manifest.inc
index 1d14654f85..3a460e562a 100644
--- a/packages/python/python-2.4.3-manifest.inc
+++ b/packages/python/python-2.4.3-manifest.inc
@@ -124,7 +124,7 @@ FILES_python-tkinter="${libdir}/python2.4/lib-dynload/_tkinter.so ${libdir}/pyth
DESCRIPTION_python-gdbm="Python GNU Database Support"
PR_python-gdbm="ml0"
-RDEPENDS_python-gdbm="python-core libgdbm3"
+RDEPENDS_python-gdbm="python-core"
FILES_python-gdbm="${libdir}/python2.4/lib-dynload/gdbm.so "
DESCRIPTION_python-fcntl="Python's fcntl Interface"
@@ -164,7 +164,7 @@ FILES_python-html="${libdir}/python2.4/formatter.* ${libdir}/python2.4/htmlentit
DESCRIPTION_python-readline="Python Readline Support"
PR_python-readline="ml0"
-RDEPENDS_python-readline="python-core libreadline4"
+RDEPENDS_python-readline="python-core"
FILES_python-readline="${libdir}/python2.4/lib-dynload/readline.so ${libdir}/python2.4/rlcompleter.* "
DESCRIPTION_python-subprocess="Python Subprocess Support"
diff --git a/packages/python/python_2.4.3.bb b/packages/python/python_2.4.3.bb
index 30c4ee1aee..2af6789b7a 100644
--- a/packages/python/python_2.4.3.bb
+++ b/packages/python/python_2.4.3.bb
@@ -6,7 +6,7 @@ PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
DEPENDS = "python-native readline zlib gdbm openssl tcl tk"
DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
-PR = "ml5"
+PR = "ml6"
PYTHON_MAJMIN = "2.4"
@@ -68,5 +68,5 @@ require python-${PV}-manifest.inc
RPROVIDES_python-core = "python"
RPROVIDES_python-curses = "python"
PACKAGES =+ "libpython2"
-PACKAGES_DYNAMIC = "python-* libpython2"
+PACKAGES_DYNAMIC = "libpython2"
FILES_libpython2 = "${libdir}/libpython*"