aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorMatt Reimer <mattjreimer@gmail.com>2006-10-27 23:31:05 +0000
committerMatt Reimer <mattjreimer@gmail.com>2006-10-27 23:31:05 +0000
commitddcf499302c0c8d6b542e5b63068390be82beda6 (patch)
tree527d44bb782fefc6ff67665e74f725bfd550d90c /packages/python
parent529911a67e564b4c8ff9580e2ca0d5e85b638671 (diff)
downloadopenembedded-ddcf499302c0c8d6b542e5b63068390be82beda6.tar.gz
sword and python-sword: upgrade to 1.5.9.
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-sword_1.5.9.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/python/python-sword_1.5.9.bb b/packages/python/python-sword_1.5.9.bb
new file mode 100644
index 0000000000..6c777bb54d
--- /dev/null
+++ b/packages/python/python-sword_1.5.9.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Python bindings for the sword library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python-core sword"
+DEPENDS = "sword-${PV} swig-native"
+SRCNAME = "sword"
+PR = "r0"
+
+SRC_URI = "http://crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}/bindings/swig/package"
+
+EXTRA_OECONF = "--with-sword-dir=${STAGING_DIR}/${HOST_SYS}"
+
+inherit distutils autotools
+
+PARALLEL_MAKE = ""
+
+#do_configure_prepend() {
+# ./autogen.sh
+#}
+
+do_compile() {
+ oe_runmake BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} pythonswig python_make
+}
+
+do_install() {
+ cd ${S}/python
+ distutils_do_install
+}