aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-02-04 20:27:49 +0100
committerKoen Kooi <koen@openembedded.org>2009-02-04 20:27:49 +0100
commit1bd27c48b538fb4e29128cadcf92e975d578446c (patch)
tree29a043ac3cf28e32e45d857a695b7f2ad535bd89 /packages/python
parent5e833c9fbb13ec62f3c3be166eba78fc8567b2ad (diff)
downloadopenembedded-1bd27c48b538fb4e29128cadcf92e975d578446c.tar.gz
python-twisted: attempt to fix packaging
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-twisted_8.2.0.bb22
1 files changed, 19 insertions, 3 deletions
diff --git a/packages/python/python-twisted_8.2.0.bb b/packages/python/python-twisted_8.2.0.bb
index 7061866aec..78234187fb 100644
--- a/packages/python/python-twisted_8.2.0.bb
+++ b/packages/python/python-twisted_8.2.0.bb
@@ -5,12 +5,12 @@ HOMEPAGE = "http://www.twistedmatrix.com"
SECTION = "console/network"
PRIORITY = "optional"
LICENSE = "LGPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/8.2/Twisted-${PV}.tar.bz2 "
S = "${WORKDIR}/Twisted-${PV}"
-inherit distutils
+inherit setuptools
PACKAGES += "\
${PN}-zsh \
@@ -25,6 +25,8 @@ PACKAGES += "\
${PN}-runner \
${PN}-web \
${PN}-words \
+ ${PN}-flow \
+ ${PN}-pair \
${PN}-core \
"
@@ -67,6 +69,7 @@ FILES_${PN}-conch = " \
${bindir}/tkconch \
${bindir}/conch \
${bindir}/conchftp \
+ ${bindir}/cftp \
${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \
"
@@ -80,6 +83,8 @@ ${bindir}/tap2rpm \
${bindir}/tapconvert \
${bindir}/tkmktap \
${bindir}/trial \
+${bindir}/easy_install* \
+${bindir}/pyhtmlizer \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \
@@ -147,7 +152,9 @@ ${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugin.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \
"
FILES_${PN}-lore = " \
@@ -190,6 +197,15 @@ ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/words\
"
+FILES_${PN}-flow = " \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \"
+
+FILES_${PN}-pair = " \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \
+"
+
FILES_${PN}-dbg += " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \