aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qemu
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2008-02-03 00:15:59 +0000
committerRichard Purdie <rpurdie@rpsys.net>2008-02-03 00:15:59 +0000
commit01f0994efc30b67cfccc803ddb1fa902d6b2d949 (patch)
tree44a7648aeb52dd1e89e5c6f2757b29a757fca896 /packages/qemu
parente3e8f31ef232a80edd2556edc87bd4a09c373a64 (diff)
downloadopenembedded-01f0994efc30b67cfccc803ddb1fa902d6b2d949.tar.gz
qemu: Fix writev syscall null value handling, fixes glibc LC_CTYPE errors during locale generation
Diffstat (limited to 'packages/qemu')
-rw-r--r--packages/qemu/qemu-0.9.1/writev_fix.patch17
-rw-r--r--packages/qemu/qemu_0.9.1.bb3
2 files changed, 19 insertions, 1 deletions
diff --git a/packages/qemu/qemu-0.9.1/writev_fix.patch b/packages/qemu/qemu-0.9.1/writev_fix.patch
new file mode 100644
index 0000000000..e0ed4af972
--- /dev/null
+++ b/packages/qemu/qemu-0.9.1/writev_fix.patch
@@ -0,0 +1,17 @@
+---
+ linux-user/syscall.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: qemu-0.9.1/linux-user/syscall.c
+===================================================================
+--- qemu-0.9.1.orig/linux-user/syscall.c 2008-02-03 00:00:00.000000000 +0000
++++ qemu-0.9.1/linux-user/syscall.c 2008-02-03 00:00:38.000000000 +0000
+@@ -1048,7 +1048,7 @@ static abi_long lock_iovec(int type, str
+ base = tswapl(target_vec[i].iov_base);
+ vec[i].iov_len = tswapl(target_vec[i].iov_len);
+ vec[i].iov_base = lock_user(type, base, vec[i].iov_len, copy);
+- if (!vec[i].iov_base)
++ if (!vec[i].iov_base && vec[i].iov_len)
+ goto fail;
+ }
+ unlock_user (target_vec, target_addr, 0);
diff --git a/packages/qemu/qemu_0.9.1.bb b/packages/qemu/qemu_0.9.1.bb
index 2f0aba7e64..164296b0d4 100644
--- a/packages/qemu/qemu_0.9.1.bb
+++ b/packages/qemu/qemu_0.9.1.bb
@@ -1,6 +1,6 @@
LICENSE = "GPL"
DEPENDS = "zlib"
-PR = "r6"
+PR = "r7"
FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
FILESDIR = "${WORKDIR}"
@@ -31,6 +31,7 @@ SRC_URI = "\
file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
file://workaround_bad_futex_headers.patch;patch=1 \
file://fix_segfault.patch;patch=1 \
+ file://writev_fix.patch;patch=1 \
file://configure_symlinkpath_fix.patch;patch=1 \
file://disable-error-in-configure.patch;patch=1 \
file://no-strip.patch;patch=1"