aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qemu
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2008-01-28 21:43:52 +0000
committerRichard Purdie <rpurdie@rpsys.net>2008-01-28 21:43:52 +0000
commit6244c13450c89414df2fe9189daa6a3f0fdf3163 (patch)
treee636611f33bf6fe89661e11ff95936efc451a9fc /packages/qemu
parentd3422da17dbc0353f7ca8e6c8202201b3ff54af2 (diff)
downloadopenembedded-6244c13450c89414df2fe9189daa6a3f0fdf3163.tar.gz
qemu: Fix missing inherit native and cleanup various files
Diffstat (limited to 'packages/qemu')
-rw-r--r--packages/qemu/qemu-native.inc6
-rw-r--r--packages/qemu/qemu-native_20070613.bb5
-rw-r--r--packages/qemu/qemu-native_cvs.bb1
-rw-r--r--packages/qemu/qemu_0.9.1.bb11
-rw-r--r--packages/qemu/qemu_20070613.bb10
-rw-r--r--packages/qemu/qemu_cvs.bb67
6 files changed, 53 insertions, 47 deletions
diff --git a/packages/qemu/qemu-native.inc b/packages/qemu/qemu-native.inc
index a20f5056b5..c0e8f89bd0 100644
--- a/packages/qemu/qemu-native.inc
+++ b/packages/qemu/qemu-native.inc
@@ -1,8 +1,6 @@
-FILESPATH =. "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/qemu-${PV}:"
+inherit native
+
DEPENDS = "libsdl-native zlib-native"
require qemu-gcc3-check.inc
-do_stage() {
- find . -name "qemu-*" -type f -perm -755 -exec install -m 0755 {} ${STAGING_BINDIR} \;
-}
diff --git a/packages/qemu/qemu-native_20070613.bb b/packages/qemu/qemu-native_20070613.bb
index d440d560e8..dc9852bd8c 100644
--- a/packages/qemu/qemu-native_20070613.bb
+++ b/packages/qemu/qemu-native_20070613.bb
@@ -1,7 +1,4 @@
require qemu_${PV}.bb
-inherit native
-DEPENDS = "zlib-native"
-prefix = "${STAGING_DIR_NATIVE}/${layout_prefix}"
+require qemu-native.inc
-require qemu-gcc3-check.inc
diff --git a/packages/qemu/qemu-native_cvs.bb b/packages/qemu/qemu-native_cvs.bb
index 639f9a6a7c..c9db5e35b9 100644
--- a/packages/qemu/qemu-native_cvs.bb
+++ b/packages/qemu/qemu-native_cvs.bb
@@ -1,3 +1,2 @@
require qemu_cvs.bb
-inherit native
require qemu-native.inc
diff --git a/packages/qemu/qemu_0.9.1.bb b/packages/qemu/qemu_0.9.1.bb
index 41194ff73f..59aa55bbed 100644
--- a/packages/qemu/qemu_0.9.1.bb
+++ b/packages/qemu/qemu_0.9.1.bb
@@ -2,7 +2,7 @@ LICENSE = "GPL"
DEPENDS = "zlib"
PR = "r4"
-FILESPATH = "${FILE_DIRNAME}/qemu-${PV}:${FILE_DIRNAME}/files"
+FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
FILESDIR = "${WORKDIR}"
SRC_URI = "\
@@ -34,15 +34,6 @@ SRC_URI = "\
file://configure_symlinkpath_fix.patch;patch=1 \
file://disable-error-in-configure.patch;patch=1"
-# svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20070119 \
-# file://debian/patches/21_net_soopts.patch;patch=1;pnum=0 \
-# file://debian/patches/35_syscall_sockaddr.patch;patch=1;pnum=0 \
-# file://debian/patches/43_arm_cpustate.patch;patch=1;pnum=0 \
-# file://debian/patches/62_linux_boot_nasm.patch;patch=1;pnum=0 \
-# file://debian/patches/67_ppc_ftbfs.patch;patch=1;pnum=0 \
-# file://debian/patches/80_ui_curses.patch;patch=1;pnum=0 \
-# file://debian/patches/96-x.patch;patch=1"
-
S = "${WORKDIR}/qemu-${PV}"
#EXTRA_OECONF += "--disable-sdl"
diff --git a/packages/qemu/qemu_20070613.bb b/packages/qemu/qemu_20070613.bb
index 6584bcc3ed..533848963b 100644
--- a/packages/qemu/qemu_20070613.bb
+++ b/packages/qemu/qemu_20070613.bb
@@ -4,6 +4,7 @@ SRCDATE = "20070613"
PV = "0.9.0+cvs${SRCDATE}"
PR = "r5"
+FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
FILESDIR = "${WORKDIR}"
SRC_URI = "\
@@ -37,15 +38,6 @@ SRC_URI = "\
file://fix_segfault.patch;patch=1 \
file://no-strip.patch;patch=1"
-# svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20070119 \
-# file://debian/patches/21_net_soopts.patch;patch=1;pnum=0 \
-# file://debian/patches/35_syscall_sockaddr.patch;patch=1;pnum=0 \
-# file://debian/patches/43_arm_cpustate.patch;patch=1;pnum=0 \
-# file://debian/patches/62_linux_boot_nasm.patch;patch=1;pnum=0 \
-# file://debian/patches/67_ppc_ftbfs.patch;patch=1;pnum=0 \
-# file://debian/patches/80_ui_curses.patch;patch=1;pnum=0 \
-# file://debian/patches/96-x.patch;patch=1"
-
S = "${WORKDIR}/qemu"
#EXTRA_OECONF = "--disable-sdl"
diff --git a/packages/qemu/qemu_cvs.bb b/packages/qemu/qemu_cvs.bb
index d76bfa2834..137262ca2d 100644
--- a/packages/qemu/qemu_cvs.bb
+++ b/packages/qemu/qemu_cvs.bb
@@ -1,26 +1,55 @@
-DESCRIPTION = "Qemu is an open source processor emulator."
-HOMEPAGE = "http://fabrice.bellard.free.fr/qemu/"
-SECTION = "devel"
LICENSE = "GPL"
-PV = "0.8.2+cvs${SRCDATE}"
-PR = "r2"
+DEPENDS = "zlib"
+PV = "0.9.0+cvs${SRCDATE}"
+PR = "r4"
+
+DEFAULT_PREFERENCE = "-1"
+FILESDIR = "${WORKDIR}"
+
+SRC_URI = "\
+ cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \
+ file://02_snapshot_use_tmpdir.patch;patch=1;pnum=0 \
+ file://03_machines_list_no_error.patch;patch=1;pnum=0 \
+ file://04_do_not_print_rtc_freq_if_ok.patch;patch=1;pnum=1 \
+ file://05_non-fatal_if_linux_hd_missing.patch;patch=1;pnum=1 \
+ file://06_exit_segfault.patch;patch=1;pnum=0 \
+ file://10_signal_jobs.patch;patch=1;pnum=0 \
+ file://11_signal_sigaction.patch;patch=1;pnum=0 \
+ file://12_signal_powerpc_support.patch;patch=1;pnum=1 \
+ file://22_net_tuntap_stall.patch;patch=1;pnum=0 \
+ file://31_syscalls.patch;patch=1;pnum=0 \
+ file://32_syscall_sysctl.patch;patch=1;pnum=0 \
+ file://33_syscall_ppc_clone.patch;patch=1;pnum=0 \
+ file://39_syscall_fadvise64.patch;patch=1;pnum=0 \
+ file://41_arm_fpa_sigfpe.patch;patch=1;pnum=0 \
+ file://52_ne2000_return.patch;patch=1;pnum=1 \
+ file://61_safe_64bit_int.patch;patch=1;pnum=0 \
+ file://63_sparc_build.patch;patch=1;pnum=0 \
+ file://64_ppc_asm_constraints.patch;patch=1;pnum=1 \
+ file://65_kfreebsd.patch;patch=1;pnum=0 \
+ file://66_tls_ld.patch;patch=1;pnum=0 \
+ file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \
+ file://93-oh-pl110-rgb.patch;patch=1;pnum=0 \
+ file://qemu-0.9.0-nptl.patch;patch=1 \
+ file://qemu-0.9.0-nptl-update.patch;patch=1 \
+ file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
+ file://workaround_bad_futex_headers.patch;patch=1 \
+ file://fix_segfault.patch;patch=1"
+
+# svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20070119 \
+# file://debian/patches/21_net_soopts.patch;patch=1;pnum=0 \
+# file://debian/patches/35_syscall_sockaddr.patch;patch=1;pnum=0 \
+# file://debian/patches/43_arm_cpustate.patch;patch=1;pnum=0 \
+# file://debian/patches/62_linux_boot_nasm.patch;patch=1;pnum=0 \
+# file://debian/patches/67_ppc_ftbfs.patch;patch=1;pnum=0 \
+# file://debian/patches/80_ui_curses.patch;patch=1;pnum=0 \
+# file://debian/patches/96-x.patch;patch=1"
-SRC_URI = "cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \
- file://configure.patch;patch=1 \
- file://makefile.patch;patch=1 \
- file://qemu-sdl-cursor.patch;patch=1 \
- file://arm_nptl.patch;patch=1 \
- file://pl110_rgb-r0.patch;patch=1 \
- file://qemu-pci-irq-sharing.patch;patch=1 \
- file://compiler.patch;patch=1 \
- file://qemu-usb-wacom-0.8.2.patch;patch=1 \
- file://qemu-usb-wacom-pressure.patch;patch=1 \
- file://qemu-usb-wacom-buttons.patch;patch=1 \
- http://www.busybox.net/downloads/qemu/qemu-gcc-4-all.patch;patch=1"
S = "${WORKDIR}/qemu"
-EXTRA_OECONF="--disable-gcc-check"
+#EXTRA_OECONF += "--disable-sdl"
+#EXTRA_OECONF += "--target-list=arm-linux-user"
+EXTRA_OECONF += "--disable-gfx-check"
inherit autotools
-DEFAULT_PREFERENCE = "-1"