aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qemu
diff options
context:
space:
mode:
authorDmitry Baryshkov <dbaryshkov@gmail.com>2008-12-01 04:31:52 +0300
committerDmitry Baryshkov <dbaryshkov@gmail.com>2008-12-04 16:58:51 +0300
commit8ad80633a45048351695897162f5a2bd94057c8f (patch)
tree12be729268ff45ebda7cfaeaa5da8179a6f63ddc /packages/qemu
parent85e93fe72e2a0129c12f118eb6dc9f2d2040f488 (diff)
downloadopenembedded-8ad80633a45048351695897162f5a2bd94057c8f.tar.gz
qemu-svn: fix hw/baum.c compilation
The SDL code in hw/baum.c assumes that SDL is compiled with X11 driver If that is not the case, compilation will fail. Fix that by explicitly checking for SDL_VIDEO_DRIVER_X11 Signed-off-by: Dmitry Baryshkov <dbaryshkov@gmail.com>
Diffstat (limited to 'packages/qemu')
-rw-r--r--packages/qemu/qemu-0.9.1+svn/fix_baum_c_compilation.patch30
-rw-r--r--packages/qemu/qemu_svn.bb3
2 files changed, 32 insertions, 1 deletions
diff --git a/packages/qemu/qemu-0.9.1+svn/fix_baum_c_compilation.patch b/packages/qemu/qemu-0.9.1+svn/fix_baum_c_compilation.patch
new file mode 100644
index 0000000000..a2eb438ed9
--- /dev/null
+++ b/packages/qemu/qemu-0.9.1+svn/fix_baum_c_compilation.patch
@@ -0,0 +1,30 @@
+Index: trunk/hw/baum.c
+===================================================================
+--- trunk.orig/hw/baum.c 2008-11-29 05:12:40.418390606 +0300
++++ trunk/hw/baum.c 2008-11-29 05:13:11.498378426 +0300
+@@ -569,8 +569,10 @@ CharDriverState *chr_baum_init(void)
+ CharDriverState *chr;
+ brlapi_handle_t *handle;
+ #ifdef CONFIG_SDL
++#ifdef SDL_VIDEO_DRIVER_X11
+ SDL_SysWMinfo info;
+ #endif
++#endif
+ int tty;
+
+ baum = qemu_mallocz(sizeof(BaumDriverState));
+@@ -605,12 +607,14 @@ CharDriverState *chr_baum_init(void)
+ }
+
+ #ifdef CONFIG_SDL
++#ifdef SDL_VIDEO_DRIVER_X11
+ memset(&info, 0, sizeof(info));
+ SDL_VERSION(&info.version);
+ if (SDL_GetWMInfo(&info))
+ tty = info.info.x11.wmwindow;
+ else
+ #endif
++#endif
+ tty = BRLAPI_TTY_DEFAULT;
+
+ if (brlapi__enterTtyMode(handle, tty, NULL) == -1) {
diff --git a/packages/qemu/qemu_svn.bb b/packages/qemu/qemu_svn.bb
index e8d9883c74..b4acae7cda 100644
--- a/packages/qemu/qemu_svn.bb
+++ b/packages/qemu/qemu_svn.bb
@@ -1,7 +1,7 @@
LICENSE = "GPL"
DEPENDS = "zlib"
PV = "0.9.1+svnr${SRCREV}"
-PR = "r13"
+PR = "r14"
FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-0.9.1+svn/"
@@ -34,6 +34,7 @@ SRC_URI = "\
file://fix_protection_bits.patch;patch=1 \
file://revert_arm_tcg.patch.gz;patch=1;minrev=4242 \
file://qemu-n800-support.patch;patch=1 \
+ file://fix_baum_c_compilation.patch;patch=1 \
file://fix_dirent_h_include.patch;patch=1"
S = "${WORKDIR}/trunk"