aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qemu
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-08-26 17:40:06 +0000
committerRichard Purdie <rpurdie@rpsys.net>2006-08-26 17:40:06 +0000
commitcedf219f704f423b219b602de22b1ea7663df189 (patch)
tree726312c2c62774b4035b1f846236158be0e83175 /packages/qemu
parenteda54eb6defc01f75d6cc5b4e604911375592f2b (diff)
downloadopenembedded-cedf219f704f423b219b602de22b1ea7663df189.tar.gz
qemu cvs: Update SRCDATE to 20060723
Diffstat (limited to 'packages/qemu')
-rw-r--r--packages/qemu/files/arm_nptl.patch86
-rw-r--r--packages/qemu/qemu_cvs.bb4
2 files changed, 44 insertions, 46 deletions
diff --git a/packages/qemu/files/arm_nptl.patch b/packages/qemu/files/arm_nptl.patch
index 958c27e5e1..f9b10aebc5 100644
--- a/packages/qemu/files/arm_nptl.patch
+++ b/packages/qemu/files/arm_nptl.patch
@@ -1,25 +1,25 @@
Index: qemu/configure
===================================================================
---- qemu.orig/configure 2006-08-14 22:09:39.000000000 +0100
-+++ qemu/configure 2006-08-14 22:38:54.000000000 +0100
-@@ -96,6 +96,7 @@
- user="no"
+--- qemu.orig/configure 2006-08-26 16:31:53.000000000 +0100
++++ qemu/configure 2006-08-26 16:31:53.000000000 +0100
+@@ -97,6 +97,7 @@
build_docs="no"
+ build_acpi_tables="no"
uname_release=""
+nptl="yes"
# OS specific
targetos=`uname -s`
-@@ -240,6 +241,8 @@
+@@ -243,6 +244,8 @@
;;
- --enable-uname-release=*) uname_release="$optarg"
+ --enable-iasl) build_acpi_tables="yes"
;;
+ --disable-nptl) nptl="no"
+ ;;
esac
done
-@@ -438,6 +441,23 @@
+@@ -441,6 +444,23 @@
fi
fi
@@ -43,7 +43,7 @@ Index: qemu/configure
##########################################
# SDL probe
-@@ -556,6 +576,7 @@
+@@ -559,6 +579,7 @@
fi
echo "FMOD support $fmod $fmod_support"
echo "kqemu support $kqemu"
@@ -51,7 +51,7 @@ Index: qemu/configure
echo "Documentation $build_docs"
[ ! -z "$uname_release" ] && \
echo "uname -r $uname_release"
-@@ -864,6 +885,14 @@
+@@ -880,6 +901,14 @@
echo "SDL_CFLAGS=`$sdl_config --cflags`" >> $config_mak
fi
fi
@@ -68,8 +68,8 @@ Index: qemu/configure
if test "$cocoa" = "yes" ; then
Index: qemu/exec-all.h
===================================================================
---- qemu.orig/exec-all.h 2006-05-26 18:10:52.000000000 +0100
-+++ qemu/exec-all.h 2006-08-14 22:37:29.000000000 +0100
+--- qemu.orig/exec-all.h 2006-08-26 16:28:32.000000000 +0100
++++ qemu/exec-all.h 2006-08-26 16:31:53.000000000 +0100
@@ -347,163 +347,7 @@
extern CPUReadMemoryFunc *io_mem_read[IO_MEM_NB_ENTRIES][4];
extern void *io_mem_opaque[IO_MEM_NB_ENTRIES];
@@ -237,8 +237,8 @@ Index: qemu/exec-all.h
Index: qemu/linux-user/arm/syscall.h
===================================================================
---- qemu.orig/linux-user/arm/syscall.h 2005-04-27 21:11:21.000000000 +0100
-+++ qemu/linux-user/arm/syscall.h 2006-08-14 22:37:29.000000000 +0100
+--- qemu.orig/linux-user/arm/syscall.h 2006-03-09 19:18:11.000000000 +0000
++++ qemu/linux-user/arm/syscall.h 2006-08-26 16:31:53.000000000 +0100
@@ -28,7 +28,9 @@
#define ARM_SYSCALL_BASE 0x900000
#define ARM_THUMB_SYSCALL 0
@@ -252,9 +252,9 @@ Index: qemu/linux-user/arm/syscall.h
#define ARM_NR_thumb_semihosting 0xAB
Index: qemu/linux-user/main.c
===================================================================
---- qemu.orig/linux-user/main.c 2006-05-26 18:11:01.000000000 +0100
-+++ qemu/linux-user/main.c 2006-08-14 22:37:29.000000000 +0100
-@@ -331,6 +331,50 @@
+--- qemu.orig/linux-user/main.c 2006-08-26 16:28:40.000000000 +0100
++++ qemu/linux-user/main.c 2006-08-26 16:31:53.000000000 +0100
+@@ -309,6 +309,50 @@
}
}
@@ -305,7 +305,7 @@ Index: qemu/linux-user/main.c
void cpu_loop(CPUARMState *env)
{
int trapnr;
-@@ -387,10 +431,8 @@
+@@ -365,10 +409,8 @@
}
}
@@ -318,7 +318,7 @@ Index: qemu/linux-user/main.c
env->regs[0] = do_arm_semihosting (env);
} else if (n == 0 || n >= ARM_SYSCALL_BASE
|| (env->thumb && n == ARM_THUMB_SYSCALL)) {
-@@ -401,14 +443,34 @@
+@@ -379,14 +421,34 @@
n -= ARM_SYSCALL_BASE;
env->eabi = 0;
}
@@ -361,7 +361,7 @@ Index: qemu/linux-user/main.c
} else {
goto error;
}
-@@ -447,6 +509,10 @@
+@@ -425,6 +487,10 @@
}
}
break;
@@ -372,7 +372,7 @@ Index: qemu/linux-user/main.c
default:
error:
fprintf(stderr, "qemu: unhandled CPU exception 0x%x - aborting\n",
-@@ -1649,6 +1715,10 @@
+@@ -1639,6 +1705,10 @@
ts->heap_base = info->brk;
/* This will be filled in on the first SYS_HEAPINFO call. */
ts->heap_limit = 0;
@@ -385,22 +385,22 @@ Index: qemu/linux-user/main.c
{
Index: qemu/linux-user/qemu.h
===================================================================
---- qemu.orig/linux-user/qemu.h 2006-05-26 18:11:01.000000000 +0100
-+++ qemu/linux-user/qemu.h 2006-08-14 22:37:29.000000000 +0100
-@@ -76,6 +76,9 @@
+--- qemu.orig/linux-user/qemu.h 2006-08-26 16:28:40.000000000 +0100
++++ qemu/linux-user/qemu.h 2006-08-26 16:33:50.000000000 +0100
+@@ -75,6 +75,9 @@
uint32_t v86mask;
#endif
int used; /* non zero if used */
+#ifdef USE_NPTL
+ uint32_t *child_tidptr;
+#endif
+ struct image_info *info;
uint8_t stack[0];
} __attribute__((aligned(16))) TaskState;
-
Index: qemu/linux-user/syscall.c
===================================================================
---- qemu.orig/linux-user/syscall.c 2006-05-26 18:11:01.000000000 +0100
-+++ qemu/linux-user/syscall.c 2006-08-14 22:44:47.000000000 +0100
+--- qemu.orig/linux-user/syscall.c 2006-08-26 16:28:40.000000000 +0100
++++ qemu/linux-user/syscall.c 2006-08-26 16:31:53.000000000 +0100
@@ -66,9 +66,18 @@
#include <linux/kd.h>
@@ -420,7 +420,7 @@ Index: qemu/linux-user/syscall.c
#if defined(TARGET_I386) || defined(TARGET_ARM) || defined(TARGET_SPARC)
/* 16 bit uid wrappers emulation */
#define USE_UID16
-@@ -1569,20 +1578,38 @@
+@@ -1602,20 +1611,38 @@
thread/process */
#define NEW_STACK_SIZE 8192
@@ -460,7 +460,7 @@ Index: qemu/linux-user/syscall.c
if (flags & CLONE_VM) {
ts = malloc(sizeof(TaskState) + NEW_STACK_SIZE);
-@@ -1627,16 +1654,60 @@
+@@ -1665,16 +1692,60 @@
#error unsupported target CPU
#endif
new_env->opaque = ts;
@@ -525,7 +525,7 @@ Index: qemu/linux-user/syscall.c
}
return ret;
}
-@@ -1880,7 +1951,7 @@
+@@ -1918,7 +1989,7 @@
ret = do_brk(arg1);
break;
case TARGET_NR_fork:
@@ -534,7 +534,7 @@ Index: qemu/linux-user/syscall.c
break;
case TARGET_NR_waitpid:
{
-@@ -2836,7 +2907,8 @@
+@@ -2989,7 +3060,8 @@
ret = get_errno(fsync(arg1));
break;
case TARGET_NR_clone:
@@ -544,7 +544,7 @@ Index: qemu/linux-user/syscall.c
break;
#ifdef __NR_exit_group
/* new thread calls */
-@@ -3186,7 +3258,8 @@
+@@ -3339,7 +3411,8 @@
#endif
#ifdef TARGET_NR_vfork
case TARGET_NR_vfork:
@@ -554,15 +554,15 @@ Index: qemu/linux-user/syscall.c
break;
#endif
#ifdef TARGET_NR_ugetrlimit
-@@ -3681,4 +3754,3 @@
+@@ -3838,4 +3911,3 @@
#endif
return ret;
}
-
Index: qemu/target-arm/cpu.h
===================================================================
---- qemu.orig/target-arm/cpu.h 2006-02-20 00:33:36.000000000 +0000
-+++ qemu/target-arm/cpu.h 2006-08-14 22:39:35.000000000 +0100
+--- qemu.orig/target-arm/cpu.h 2006-03-09 19:18:27.000000000 +0000
++++ qemu/target-arm/cpu.h 2006-08-26 16:31:53.000000000 +0100
@@ -35,6 +35,9 @@
#define EXCP_IRQ 5
#define EXCP_FIQ 6
@@ -612,8 +612,8 @@ Index: qemu/target-arm/cpu.h
/* Return the current CPSR value. */
Index: qemu/target-arm/exec.h
===================================================================
---- qemu.orig/target-arm/exec.h 2005-11-26 10:38:39.000000000 +0000
-+++ qemu/target-arm/exec.h 2006-08-14 22:37:29.000000000 +0100
+--- qemu.orig/target-arm/exec.h 2006-03-09 19:18:27.000000000 +0000
++++ qemu/target-arm/exec.h 2006-08-26 16:31:53.000000000 +0100
@@ -51,8 +51,6 @@
/* In op_helper.c */
@@ -625,8 +625,8 @@ Index: qemu/target-arm/exec.h
Index: qemu/target-arm/op.c
===================================================================
---- qemu.orig/target-arm/op.c 2006-02-20 00:33:36.000000000 +0000
-+++ qemu/target-arm/op.c 2006-08-14 22:37:29.000000000 +0100
+--- qemu.orig/target-arm/op.c 2006-08-26 16:28:48.000000000 +0100
++++ qemu/target-arm/op.c 2006-08-26 16:31:53.000000000 +0100
@@ -891,6 +891,12 @@
cpu_loop_exit();
}
@@ -642,9 +642,9 @@ Index: qemu/target-arm/op.c
"d" suffix. */
Index: qemu/target-arm/translate.c
===================================================================
---- qemu.orig/target-arm/translate.c 2006-05-26 18:11:04.000000000 +0100
-+++ qemu/target-arm/translate.c 2006-08-14 22:37:29.000000000 +0100
-@@ -2377,6 +2377,7 @@
+--- qemu.orig/target-arm/translate.c 2006-08-26 16:28:48.000000000 +0100
++++ qemu/target-arm/translate.c 2006-08-26 16:31:53.000000000 +0100
+@@ -2382,6 +2382,7 @@
s->is_jmp = DISAS_JUMP;
}
@@ -652,7 +652,7 @@ Index: qemu/target-arm/translate.c
/* generate intermediate code in gen_opc_buf and gen_opparam_buf for
basic block 'tb'. If search_pc is TRUE, also generate PC
information for each intermediate instruction. */
-@@ -2411,6 +2412,15 @@
+@@ -2416,6 +2417,15 @@
nb_gen_labels = 0;
lj = -1;
do {
@@ -671,7 +671,7 @@ Index: qemu/target-arm/translate.c
Index: qemu/qemu_spinlock.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ qemu/qemu_spinlock.h 2006-08-14 22:37:29.000000000 +0100
++++ qemu/qemu_spinlock.h 2006-08-26 16:31:53.000000000 +0100
@@ -0,0 +1,182 @@
+/*
+ * internal execution defines for qemu
diff --git a/packages/qemu/qemu_cvs.bb b/packages/qemu/qemu_cvs.bb
index a44ff2bdbc..0dfe01aa11 100644
--- a/packages/qemu/qemu_cvs.bb
+++ b/packages/qemu/qemu_cvs.bb
@@ -1,10 +1,8 @@
LICENSE = "GPL"
-PV = "0.8.0+cvs${SRCDATE}"
-PR = "r2"
+PV = "0.8.2+cvs${SRCDATE}"
SRC_URI = "cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \
file://configure.patch;patch=1 \
- file://mouse_fix-r0.patch;patch=1 \
file://pl110_rgb-r0.patch;patch=1 \
file://arm_nptl.patch;patch=1"