aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qi/files
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-02-13 01:28:41 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-02-13 01:28:54 +0100
commit329e712274b3ca2e8edb9716f1608a083ae3ed83 (patch)
tree8f537b0e7dfa49cf5808bc5a38d6719699d48589 /packages/qi/files
parented0059d421f84310e6491305431293d382d8c5bc (diff)
downloadopenembedded-329e712274b3ca2e8edb9716f1608a083ae3ed83.tar.gz
qi: make it build working binaries
Diffstat (limited to 'packages/qi/files')
-rw-r--r--packages/qi/files/sanitize-makefile.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/qi/files/sanitize-makefile.patch b/packages/qi/files/sanitize-makefile.patch
new file mode 100644
index 0000000000..cd1abf3f58
--- /dev/null
+++ b/packages/qi/files/sanitize-makefile.patch
@@ -0,0 +1,27 @@
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -16,12 +16,6 @@
+
+ include config.mk
+
+-BUILD_DATE := $(shell date)
+-BUILD_HOST := $(shell hostname)
+-BUILD_BRANCH := $(shell git branch | grep ^\* | cut -d' ' -f2)
+-BUILD_HEAD := $(shell git show --pretty=oneline | head -n1 | cut -d' ' -f1 | cut -b1-16)
+-BUILD_VERSION := ${BUILD_BRANCH}_${BUILD_HEAD}
+-
+ LDS = src/cpu/$(CPU)/qi.lds
+ INCLUDE = include
+ IMAGE_DIR = image
+@@ -73,7 +67,7 @@ all:${UDFU_IMAGE}
+ ${OBJS}:${SRCS} ${INCLUDE}/*.h
+
+ ${MKUDFU}:
+- make -C $(TOOLS)
++ gcc tools/mkudfu.c -o ${MKUDFU} -Itools/
+
+ ${UDFU_IMAGE}:${OBJS} ${MKUDFU}
+ mkdir -p image
+