aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qiv
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-09-02 11:24:19 +0000
committerKoen Kooi <koen@openembedded.org>2006-09-02 11:24:19 +0000
commit887642656edc1a144139e805ea22376000ad016e (patch)
treef6c61f6861581043fd1ddfb82a714cf8edb95c2d /packages/qiv
parent1889b0da866ccdf181791654958f8f0b593f0eb0 (diff)
downloadopenembedded-887642656edc1a144139e805ea22376000ad016e.tar.gz
qiv: add 1.9
Diffstat (limited to 'packages/qiv')
-rw-r--r--packages/qiv/.mtn2git_empty0
-rw-r--r--packages/qiv/files/.mtn2git_empty0
-rw-r--r--packages/qiv/files/makefile.patch22
-rw-r--r--packages/qiv/qiv_1.9.bb16
4 files changed, 38 insertions, 0 deletions
diff --git a/packages/qiv/.mtn2git_empty b/packages/qiv/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/qiv/.mtn2git_empty
diff --git a/packages/qiv/files/.mtn2git_empty b/packages/qiv/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/qiv/files/.mtn2git_empty
diff --git a/packages/qiv/files/makefile.patch b/packages/qiv/files/makefile.patch
new file mode 100644
index 0000000000..42707be9b9
--- /dev/null
+++ b/packages/qiv/files/makefile.patch
@@ -0,0 +1,22 @@
+--- /tmp/Makefile 2006-09-02 13:04:25.000000000 +0200
++++ qiv-1.9/Makefile 2006-09-02 13:05:05.255780000 +0200
+@@ -4,7 +4,7 @@
+ ######################################################################
+
+ # Directory where qiv will be installed under.
+-PREFIX = /usr/local
++PREFIX = /usr/
+
+ # Font to use for statusbar in fullscreen mode
+ STATUSBAR_FONT = "fixed"
+@@ -53,10 +53,6 @@
+ # Do not edit below here!
+ ######################################################################
+
+-CC = gcc
+-CFLAGS = -O2 -Wall -fomit-frame-pointer -finline-functions \
+- -fcaller-saves -ffast-math -fno-strength-reduce \
+- -fthread-jumps #-march=pentium #-DSTAT_MACROS_BROKEN
+
+ INCLUDES = `imlib-config --cflags-gdk`
+ LIBS = `imlib-config --libs-gdk`
diff --git a/packages/qiv/qiv_1.9.bb b/packages/qiv/qiv_1.9.bb
new file mode 100644
index 0000000000..f6e96adddb
--- /dev/null
+++ b/packages/qiv/qiv_1.9.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Qiv is a very small and pretty fast gdk/Imlib image viewer."
+LICENSE = "GPLv2"
+
+DEPENDS = "gtk+-1.2 imlib"
+
+SRC_URI = "http://www.klografx.net/qiv/download/qiv-1.9-src.tgz \
+ file://makefile.patch;patch=1 \
+ "
+inherit pkgconfig binconfig
+
+CFLAGS += " -lSM -lICE -lXdmcp"
+
+do_install() {
+ install -s -m 0755 qiv ${D}${bindir}/qiv
+ install -m 0644 qiv.1 ${D}${mandir}/man1/qiv.1
+}