aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qmake
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-12-24 13:06:51 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-12-24 13:06:51 +0000
commit002a9062fcb728cf4eb1e452befddde794cc5d23 (patch)
tree39a14d66874840f1970c161f4940100e8632ffd0 /packages/qmake
parentc24bdfa07920d585280cb0414f44693b2770daee (diff)
downloadopenembedded-002a9062fcb728cf4eb1e452befddde794cc5d23.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2004/12/24 14:06:42+01:00 uni-frankfurt.de!mickeyl qmake 1.08a uses a couple of features only present in newer moc and uic versions. This patch removes those features to make it work with our ancient Qt/E 2.x :/ BKrev: 41cc146bGpMFy5H63DbCi9k1KVw0YA
Diffstat (limited to 'packages/qmake')
-rw-r--r--packages/qmake/qmake-native-1.08a/old-moc-compatibility.patch0
-rw-r--r--packages/qmake/qmake-native-1.08a/old-uic-compatibility.patch0
-rw-r--r--packages/qmake/qmake-native_1.08a.bb54
3 files changed, 54 insertions, 0 deletions
diff --git a/packages/qmake/qmake-native-1.08a/old-moc-compatibility.patch b/packages/qmake/qmake-native-1.08a/old-moc-compatibility.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/qmake/qmake-native-1.08a/old-moc-compatibility.patch
diff --git a/packages/qmake/qmake-native-1.08a/old-uic-compatibility.patch b/packages/qmake/qmake-native-1.08a/old-uic-compatibility.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/qmake/qmake-native-1.08a/old-uic-compatibility.patch
diff --git a/packages/qmake/qmake-native_1.08a.bb b/packages/qmake/qmake-native_1.08a.bb
index e69de29bb2..a310301c87 100644
--- a/packages/qmake/qmake-native_1.08a.bb
+++ b/packages/qmake/qmake-native_1.08a.bb
@@ -0,0 +1,54 @@
+DESCRIPTION = "TrollTech Makefile Generator"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+SECTION = "devel"
+LICENSE = "GPL|QPL"
+PR = "r2"
+
+QTEVER = "4.0.0-b1"
+
+SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-opensource-${QTEVER}.tar.bz2 \
+ file://old-moc-compatibility.patch;patch=1 \
+ file://old-uic-compatibility.patch;patch=1 \
+ file://linux-oe-qmake.conf"
+S = "${WORKDIR}/qt-embedded-opensource-${QTEVER}"
+
+inherit autotools native
+
+export QTDIR = "${S}"
+EXTRA_OEMAKE = "-e"
+
+do_configure() {
+ # Install the OE build templates (linux, linux-uclibc)
+ install -d ${S}/mkspecs/linux-oe-g++
+ install -d ${S}/mkspecs/linux-uclibc-oe-g++
+ install -m 0644 ${WORKDIR}/linux-oe-qmake.conf \
+ ${S}/mkspecs/linux-oe-g++/qmake.conf
+ ln -sf ../linux-g++/qplatformdefs.h \
+ ${S}/mkspecs/linux-oe-g++/qplatformdefs.h
+ ln -sf ../linux-oe-g++/qmake.conf \
+ ${S}/mkspecs/linux-uclibc-oe-g++/qmake.conf
+ ln -sf ../linux-g++/qplatformdefs.h \
+ ${S}/mkspecs/linux-uclibc-oe-g++/qplatformdefs.h
+
+ QMAKESPEC=
+ PLATFORM=${HOST_OS}-oe-g++
+ export PLATFORM
+ oenote ./configure ${EXTRA_OECONF}
+ echo yes | ./configure ${EXTRA_OECONF} || die "Configuring qt failed"
+}
+
+do_compile() {
+ :
+}
+
+do_stage() {
+ install -m 0755 bin/qmake ${STAGING_BINDIR}
+ install -d ${QMAKE_MKSPEC_PATH}
+ cp -dfR mkspecs/* ${QMAKE_MKSPEC_PATH}
+}
+
+do_install() {
+ :
+}