aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qmake
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-12-23 00:39:08 +0000
committerHolger Freyther <zecke@selfish.org>2007-12-23 00:39:08 +0000
commit2068d289bb9a9d0c2823a110d7751ba9e72e6542 (patch)
tree1b6b3ba2d36e15f57b66aa8e3e95c8244832162d /packages/qmake
parenta4d3737a7b1dd58c2364782f0a78988dccc6aec7 (diff)
downloadopenembedded-2068d289bb9a9d0c2823a110d7751ba9e72e6542.tar.gz
packages/qmake/qmake2: Make it more easy to do updates
Create a qmake2-native.inc, get the files from qmake2-native. Recreate qmake2-native_2.10a.bb and require the above file and say which version of QtopiaCore to get.
Diffstat (limited to 'packages/qmake')
-rw-r--r--packages/qmake/qmake2-native.inc68
-rw-r--r--packages/qmake/qmake2-native/.mtn2git_empty (renamed from packages/qmake/qmake2-native-2.10a/.mtn2git_empty)0
-rw-r--r--packages/qmake/qmake2-native/0001-fix-mkspecs.patch (renamed from packages/qmake/qmake2-native-2.10a/0001-fix-mkspecs.patch)0
-rw-r--r--packages/qmake/qmake2-native/linux-oe-qmake.conf (renamed from packages/qmake/qmake2-native-2.10a/linux-oe-qmake.conf)0
-rw-r--r--packages/qmake/qmake2-native/use-lflags-last.patch (renamed from packages/qmake/qmake2-native-2.10a/use-lflags-last.patch)0
-rw-r--r--packages/qmake/qmake2-native_2.10a.bb69
6 files changed, 70 insertions, 67 deletions
diff --git a/packages/qmake/qmake2-native.inc b/packages/qmake/qmake2-native.inc
new file mode 100644
index 0000000000..eb4744ca58
--- /dev/null
+++ b/packages/qmake/qmake2-native.inc
@@ -0,0 +1,68 @@
+DESCRIPTION = "TrollTech Makefile Generator"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+SECTION = "devel"
+LICENSE = "GPL"
+PR = "r2"
+
+QTVER = "qtopia-core-opensource-src-${QTVERSION}"
+
+FILESDIR += "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/qmake2-native"
+SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/${QTVER}.tar.gz \
+ file://0001-fix-mkspecs.patch;patch=1 \
+ file://use-lflags-last.patch;patch=1 \
+ file://linux-oe-qmake.conf"
+S = "${WORKDIR}/${QTVER}"
+
+# we need the real target system here
+CROSS_SYS := "${TARGET_SYS}"
+inherit autotools cross
+
+export QTDIR = "${S}"
+EXTRA_OEMAKE = "-e"
+
+do_configure() {
+ # Install the OE build templates
+ for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++
+ do
+ install -d ${S}/mkspecs/$template
+ install -m 0644 ${WORKDIR}/linux-oe-qmake.conf ${S}/mkspecs/$template/qmake.conf
+ ln -sf ../linux-g++/qplatformdefs.h ${S}/mkspecs/$template/qplatformdefs.h
+ done
+
+ QMAKESPEC=
+ PLATFORM=${HOST_OS}-oe-g++
+ export PLATFORM
+ # yes, TARGET_SYS is correct, because this is a 'cross'-qmake-native :) :M:
+ export OE_QMAKE_CC="${CC}"
+ export OE_QMAKE_CFLAGS="${CFLAGS}"
+ export OE_QMAKE_CXX="${CXX}"
+ export OE_QMAKE_CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
+ export OE_QMAKE_LDFLAGS="${LDFLAGS}"
+ export OE_QMAKE_LINK="${CCLD}"
+ export OE_QMAKE_AR="${AR}"
+ export OE_QMAKE_STRIP="${STRIP}"
+ export OE_QMAKE_UIC="${STAGING_BINDIR_NATIVE}/uic"
+ export OE_QMAKE_MOC="${STAGING_BINDIR_NATIVE}/moc"
+ export OE_QMAKE_RCC="non-existant"
+ export OE_QMAKE_QMAKE="${STAGING_BINDIR_NATIVE}/qmake"
+ export OE_QMAKE_RPATH="-Wl,-rpath-link,"
+ echo yes | ./configure -prefix ${STAGING_DIR}/${CROSS_SYS}/qt4 ${EXTRA_OECONF} || die "Configuring qt failed"
+}
+
+do_compile() {
+ :
+}
+
+do_stage() {
+ install -m 0755 bin/qmake ${STAGING_BINDIR}/qmake2
+ install -m 0755 bin/qmake ${STAGING_BINDIR}/qmake-qt4
+ install -d ${STAGING_DIR}/${CROSS_SYS}/qt4/
+ cp -PfR mkspecs ${STAGING_DIR}/${CROSS_SYS}/qt4/
+ install -d ${STAGING_DIR}/${HOST_SYS}/qt4/
+ cp -PfR mkspecs ${STAGING_DIR}/${HOST_SYS}/qt4/
+}
+
+do_install() {
+ :
+}
diff --git a/packages/qmake/qmake2-native-2.10a/.mtn2git_empty b/packages/qmake/qmake2-native/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/qmake/qmake2-native-2.10a/.mtn2git_empty
+++ b/packages/qmake/qmake2-native/.mtn2git_empty
diff --git a/packages/qmake/qmake2-native-2.10a/0001-fix-mkspecs.patch b/packages/qmake/qmake2-native/0001-fix-mkspecs.patch
index abebfdfa27..abebfdfa27 100644
--- a/packages/qmake/qmake2-native-2.10a/0001-fix-mkspecs.patch
+++ b/packages/qmake/qmake2-native/0001-fix-mkspecs.patch
diff --git a/packages/qmake/qmake2-native-2.10a/linux-oe-qmake.conf b/packages/qmake/qmake2-native/linux-oe-qmake.conf
index f58481a693..f58481a693 100644
--- a/packages/qmake/qmake2-native-2.10a/linux-oe-qmake.conf
+++ b/packages/qmake/qmake2-native/linux-oe-qmake.conf
diff --git a/packages/qmake/qmake2-native-2.10a/use-lflags-last.patch b/packages/qmake/qmake2-native/use-lflags-last.patch
index 4197dbbf64..4197dbbf64 100644
--- a/packages/qmake/qmake2-native-2.10a/use-lflags-last.patch
+++ b/packages/qmake/qmake2-native/use-lflags-last.patch
diff --git a/packages/qmake/qmake2-native_2.10a.bb b/packages/qmake/qmake2-native_2.10a.bb
index aad7eed79d..89b2ae5a82 100644
--- a/packages/qmake/qmake2-native_2.10a.bb
+++ b/packages/qmake/qmake2-native_2.10a.bb
@@ -1,67 +1,2 @@
-DESCRIPTION = "TrollTech Makefile Generator"
-PRIORITY = "optional"
-HOMEPAGE = "http://www.trolltech.com"
-SECTION = "devel"
-LICENSE = "GPL"
-PR = "r2"
-
-QTVER = "qtopia-core-opensource-src-4.3.3"
-
-SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/${QTVER}.tar.gz \
- file://0001-fix-mkspecs.patch;patch=1 \
- file://use-lflags-last.patch;patch=1 \
- file://linux-oe-qmake.conf"
-S = "${WORKDIR}/${QTVER}"
-
-# we need the real target system here
-CROSS_SYS := "${TARGET_SYS}"
-inherit autotools cross
-
-export QTDIR = "${S}"
-EXTRA_OEMAKE = "-e"
-
-do_configure() {
- # Install the OE build templates
- for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++
- do
- install -d ${S}/mkspecs/$template
- install -m 0644 ${WORKDIR}/linux-oe-qmake.conf ${S}/mkspecs/$template/qmake.conf
- ln -sf ../linux-g++/qplatformdefs.h ${S}/mkspecs/$template/qplatformdefs.h
- done
-
- QMAKESPEC=
- PLATFORM=${HOST_OS}-oe-g++
- export PLATFORM
- # yes, TARGET_SYS is correct, because this is a 'cross'-qmake-native :) :M:
- export OE_QMAKE_CC="${CC}"
- export OE_QMAKE_CFLAGS="${CFLAGS}"
- export OE_QMAKE_CXX="${CXX}"
- export OE_QMAKE_CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
- export OE_QMAKE_LDFLAGS="${LDFLAGS}"
- export OE_QMAKE_LINK="${CCLD}"
- export OE_QMAKE_AR="${AR}"
- export OE_QMAKE_STRIP="${STRIP}"
- export OE_QMAKE_UIC="${STAGING_BINDIR_NATIVE}/uic"
- export OE_QMAKE_MOC="${STAGING_BINDIR_NATIVE}/moc"
- export OE_QMAKE_RCC="non-existant"
- export OE_QMAKE_QMAKE="${STAGING_BINDIR_NATIVE}/qmake"
- export OE_QMAKE_RPATH="-Wl,-rpath-link,"
- echo yes | ./configure -prefix ${STAGING_DIR}/${CROSS_SYS}/qt4 ${EXTRA_OECONF} || die "Configuring qt failed"
-}
-
-do_compile() {
- :
-}
-
-do_stage() {
- install -m 0755 bin/qmake ${STAGING_BINDIR}/qmake2
- install -m 0755 bin/qmake ${STAGING_BINDIR}/qmake-qt4
- install -d ${STAGING_DIR}/${CROSS_SYS}/qt4/
- cp -PfR mkspecs ${STAGING_DIR}/${CROSS_SYS}/qt4/
- install -d ${STAGING_DIR}/${HOST_SYS}/qt4/
- cp -PfR mkspecs ${STAGING_DIR}/${HOST_SYS}/qt4/
-}
-
-do_install() {
- :
-}
+QTVERSION="4.3.3"
+require ${PN}.inc