aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qmake
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-10-07 12:28:17 +0000
committerHolger Freyther <zecke@selfish.org>2007-10-07 12:28:17 +0000
commitcaf09f94b1c8d9d9dfef7302b6d3c3b5526c415b (patch)
tree218a9339788de5619c404fc02ac4181b0185ae62 /packages/qmake
parentd3dd4dafb5d9a65a55fcb29253a8f30419cbccf8 (diff)
downloadopenembedded-caf09f94b1c8d9d9dfef7302b6d3c3b5526c415b.tar.gz
packages/qmake/qmake2-native: Move the LFLAGS to the end of the linker line
Move the LFLAGS to the end of the linker line. Otherwise a package (e.g. webkit) will try to link to the library in the staging directory and not to the one recently built. Remove the unstage hack from webkit-gtk as it is not needed anymore.
Diffstat (limited to 'packages/qmake')
-rw-r--r--packages/qmake/qmake2-native-2.10a/use-lflags-last.patch22
-rw-r--r--packages/qmake/qmake2-native_2.10a.bb1
2 files changed, 23 insertions, 0 deletions
diff --git a/packages/qmake/qmake2-native-2.10a/use-lflags-last.patch b/packages/qmake/qmake2-native-2.10a/use-lflags-last.patch
new file mode 100644
index 0000000000..4197dbbf64
--- /dev/null
+++ b/packages/qmake/qmake2-native-2.10a/use-lflags-last.patch
@@ -0,0 +1,22 @@
+Index: qtopia-core-opensource-src-4.3.1/qmake/generators/unix/unixmake2.cpp
+===================================================================
+--- qtopia-core-opensource-src-4.3.1.orig/qmake/generators/unix/unixmake2.cpp 2007-10-07 13:45:26.000000000 +0200
++++ qtopia-core-opensource-src-4.3.1/qmake/generators/unix/unixmake2.cpp 2007-10-07 13:57:09.000000000 +0200
+@@ -416,7 +416,7 @@
+ t << "\n\t" << mkdir_p_asstring(destdir) << "\n\t";
+ if(!project->isEmpty("QMAKE_PRE_LINK"))
+ t << var("QMAKE_PRE_LINK") << "\n\t";
+- t << "$(LINK) $(LFLAGS) -o $(TARGET) " << incr_deps << " " << incr_objs << " $(OBJCOMP) $(LIBS)";
++ t << "$(LINK) -o $(TARGET) " << incr_deps << " " << incr_objs << " $(OBJCOMP) $(LIBS) $(LFLAGS)";
+ if(!project->isEmpty("QMAKE_POST_LINK"))
+ t << "\n\t" << var("QMAKE_POST_LINK");
+ t << endl << endl;
+@@ -430,7 +430,7 @@
+ t << mkdir_p_asstring(destdir) << "\n\t";
+ if(!project->isEmpty("QMAKE_PRE_LINK"))
+ t << var("QMAKE_PRE_LINK") << "\n\t";
+- t << "$(LINK) $(LFLAGS) -o $(TARGET) $(OBJECTS) $(OBJCOMP) $(LIBS)";
++ t << "$(LINK) -o $(TARGET) $(OBJECTS) $(OBJCOMP) $(LIBS) $(LFLAGS)";
+ if(!project->isEmpty("QMAKE_POST_LINK"))
+ t << "\n\t" << var("QMAKE_POST_LINK");
+ t << endl << endl;
diff --git a/packages/qmake/qmake2-native_2.10a.bb b/packages/qmake/qmake2-native_2.10a.bb
index 207aaaf9b5..55282e562c 100644
--- a/packages/qmake/qmake2-native_2.10a.bb
+++ b/packages/qmake/qmake2-native_2.10a.bb
@@ -9,6 +9,7 @@ QTVER = "qtopia-core-opensource-src-4.3.1"
SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/${QTVER}.tar.gz \
file://0001-fix-mkspecs.patch;patch=1 \
+ file://use-lflags-last.patch;patch=1 \
file://linux-oe-qmake.conf"
S = "${WORKDIR}/${QTVER}"