aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qmatrix
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-02-14 10:22:01 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-02-14 10:22:01 +0000
commitd264c684381ace00faa32ea710718d85c4253810 (patch)
tree8e7142c0d654bd49cd1fd5a11f36ab26c7b9057a /packages/qmatrix
parent69fade6e3c11fee16b5c369b88dc236790321f7e (diff)
downloadopenembedded-d264c684381ace00faa32ea710718d85c4253810.tar.gz
consolidate collie, shepherd, husky into the common machine c7x0. kernel 2.6 handles all three machines, for kernel 2.4 we build three different kernels for every -image build.
BKrev: 42107bc9qhsZjYvjPqkddsMIsQuYAA
Diffstat (limited to 'packages/qmatrix')
-rw-r--r--packages/qmatrix/qmatrix_1.1.0.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/packages/qmatrix/qmatrix_1.1.0.bb b/packages/qmatrix/qmatrix_1.1.0.bb
index e69de29bb2..84ed03d43c 100644
--- a/packages/qmatrix/qmatrix_1.1.0.bb
+++ b/packages/qmatrix/qmatrix_1.1.0.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "A matrix Game, Qt/Embedded based Palmtop Environments Edition"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+SECTION = "opie/games"
+LICENSE = "GPL"
+PRIORITY = "optional"
+PR = "r2"
+
+SRC_URI = "http://www.geocities.co.jp/SiliconValley-Oakland/8074/src/qmatrix-${PV}.tar.gz"
+S = "${WORKDIR}/qmatrix"
+
+inherit palmtop
+
+MACHTYPE = "sl300"
+MACHTYPE_c7x0 = "sl700"
+MACHTYPE_tosa = "sl700"
+
+do_configure_append() {
+ ln -v -f -s config/config-${MACHTYPE}.h config.h
+ ln -v -f -s config/config.mk-${MACHTYPE} config.mk
+ if [ "${MACHTYPE}" = "sl300" ]
+ then
+ ln -vfs bigFishSize.h areaSize.h
+ else
+ ln -vfs smallFishSize.h areaSize.h
+ fi
+ ln -v -f -s HiScoreRegConfig-${MACHTYPE}.h HiScoreRegConfig.h
+}
+
+do_compile_prepend() {
+ cd images && oe_runmake && cd ${S}
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/apps/Games
+ install -m 0644 desktop/qmatrix-${MACHTYPE}.desktop ${D}${palmtopdir}/apps/Games/qmatrix.desktop
+ install -d ${D}${palmtopdir}/bin
+ install -m 0755 qmatrix ${D}${palmtopdir}/bin/qmatrix
+ install -d ${D}${palmtopdir}/pics
+ install -m 0644 desktop/qmatrix.png ${D}${palmtopdir}/pics/
+ install -d ${D}${palmtopdir}/help/html/
+ install -m 0644 desktop/qmatrix.html ${D}${palmtopdir}/help/html/qmatrix.html
+}