aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qpf-fonts/qpf-qte_3.3.5.bb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-01-29 14:40:07 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-01-29 14:40:07 +0000
commit48c7883a6f0fa1820a3307d109ceb26d1bcb7a41 (patch)
tree79c49f3f558f77d440ad3d3a5d7e5382fa247bdc /packages/qpf-fonts/qpf-qte_3.3.5.bb
parentc625a292aecd1db4e36a0a9cc4b4efa1901f328e (diff)
downloadopenembedded-48c7883a6f0fa1820a3307d109ceb26d1bcb7a41.tar.gz
qpf-fonts: some major clean-up and bumping of PR after the "update-font-common" commits
* unify * drop update-qtfontdir from qte-fonts-common, it is provided by qpf-font-common * replace dependencies on qte-fonts-common with qpf-font-common * rename qte-fonts-common_3.3.5 to qpf-qte_3.3.5
Diffstat (limited to 'packages/qpf-fonts/qpf-qte_3.3.5.bb')
-rw-r--r--packages/qpf-fonts/qpf-qte_3.3.5.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/packages/qpf-fonts/qpf-qte_3.3.5.bb b/packages/qpf-fonts/qpf-qte_3.3.5.bb
new file mode 100644
index 0000000000..6ac091f29d
--- /dev/null
+++ b/packages/qpf-fonts/qpf-qte_3.3.5.bb
@@ -0,0 +1,57 @@
+require qpf.inc
+
+DESCRIPTION = "Qt/Embedded fonts version ${PV}"
+HOMEPAGE = "http://www.trolltech.com"
+LICENSE = "GPL QPL"
+PR = "r6"
+
+SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-free-${PV}.tar.bz2"
+S = "${WORKDIR}/qt-embedded-free-${PV}"
+
+do_compile() {
+ :
+}
+
+do_install() {
+ mkdir -p ${D}${sbindir}
+ mkdir -p ${D}${palmtopdir}/lib/fonts
+ cp -pPR lib/fonts/* ${D}${palmtopdir}/lib/fonts
+ # Delete all other font formats, Qt/E would have a dead slow
+ # application start time if it had to use any other font format
+ # as *.qpf ...
+ find ${D}${palmtopdir}/lib/fonts \
+ -name "*.bdf" \
+ -o -name "*.ttf" \
+ -o -name "*.pfa" \
+ -o -name "*.pfb" | xargs rm
+}
+
+PACKAGES = "qte-font-fixed"
+PROVIDES += "qte-font-fixed"
+FILES_qte-font-fixed = "${palmtopdir}/lib/fonts/fixed*"
+
+PACKAGES += "qte-font-helvetica-small"
+PROVIDES += "qte-font-helvetica-small"
+FILES_qte-font-helvetica-small = "${palmtopdir}/lib/fonts/helvetica_80*.qpf \
+ ${palmtopdir}/lib/fonts/helvetica_100*.qpf ${palmtopdir}/lib/fonts/helvetica_120*.qpf"
+
+PACKAGES += "qte-font-helvetica-large"
+PROVIDES += "qte-font-helvetica-large"
+FILES_qte-font-helvetica-large = "${palmtopdir}/lib/fonts/helvetica_140*.qpf \
+ ${palmtopdir}/lib/fonts/helvetica_180*.qpf ${palmtopdir}/lib/fonts/helvetica_240*.qpf"
+
+PACKAGES += "qte-font-smoothtimes"
+PROVIDES += "qte-font-smoothtimes"
+FILES_qte-font-smoothtimes = "${palmtopdir}/lib/fonts/smoothtimes*"
+
+PACKAGES += "qte-font-smallsmooth"
+PROVIDES += "qte-font-smallsmooth"
+FILES_qte-font-smallsmooth = "${palmtopdir}/lib/fonts/smallsmooth*"
+
+PACKAGES += "qte-font-unicode"
+PROVIDES += "qte-font-unicode"
+FILES_qte-font-unicode = "${palmtopdir}/lib/fonts/unifont*.qpf"
+
+PACKAGES += "qte-font-micro"
+PROVIDES += "qte-font-micro"
+FILES_qte-font-micro = "${palmtopdir}/lib/fonts/micro*.qpf"