aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qpphoto/qpphoto_1.0.2.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-05-13 17:11:29 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-13 17:11:29 +0000
commitc9fca51203bccf780d24a1442cb3bb73590064bd (patch)
tree812d3fc36bfb965c495fda6b270895d8ab8b4560 /packages/qpphoto/qpphoto_1.0.2.bb
parentaf5a5f02392a0f0c2f4f11ca9f942873d79f9d23 (diff)
downloadopenembedded-c9fca51203bccf780d24a1442cb3bb73590064bd.tar.gz
add qpphoto, a photo manipulation program for Opie.
bbfile and patches courtesy nicolasfr@gmail.com - thanks! closes #985
Diffstat (limited to 'packages/qpphoto/qpphoto_1.0.2.bb')
-rw-r--r--packages/qpphoto/qpphoto_1.0.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/qpphoto/qpphoto_1.0.2.bb b/packages/qpphoto/qpphoto_1.0.2.bb
new file mode 100644
index 0000000000..9cd1314bb0
--- /dev/null
+++ b/packages/qpphoto/qpphoto_1.0.2.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Painting program. Small picture editor."
+HOMEPAGE = "http://zaurus.colognearts.de/qpphoto/"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "qpPhoto"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+PR = "r0"
+
+inherit opie
+
+SRC_URI = "http://zaurus.colognearts.de/qpphoto/qpPhoto_1.0.2_src.tar.gz \
+ file://draw.patch;patch=1 \
+ file://drawview.patch;patch=1 \
+ file://drawwidget.patch;patch=1 "
+
+S = "${WORKDIR}/qpPhoto_1.0.2"
+
+do_compile() {
+ export STAGING_BINDIR=${STAGING_BINDIR}
+ oe_runmake clean
+ oe_runmake
+}
+
+do_install() {
+# install -d ${D}${palmtopdir}/apps/Applications
+ install -d ${D}${palmtopdir}/pics
+# install -d ${D}${bindir}
+
+ install -m 0644 qpPhoto.png ${D}${palmtopdir}/pics
+# install -m 0644 qpPhoto.desktop ${D}${palmtopdir}/apps/Applications
+# install -m 0755 qpPhoto ${D}${bindir}
+}
+
+# FILES_${PN} = " ${palmtopdir}/apps/Applications/qpPhoto.desktop ${palmtopdir}/pics/qpPhoto.png ${bindir}/qpPhoto "