aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qscintilla
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-05-04 11:50:48 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-04 11:50:48 +0000
commit2e051e06d50974e32d414212a01cd07d834e6062 (patch)
tree8d77e08a73595999e00750de29e798697cd1d8a3 /packages/qscintilla
parentcc32ba26daf5112c5f15af67e83ce16f3c3fc748 (diff)
downloadopenembedded-2e051e06d50974e32d414212a01cd07d834e6062.tar.gz
qscintilla: added 1.65-gpl-1.6 (build as shared, no packaged yet)
Diffstat (limited to 'packages/qscintilla')
-rw-r--r--packages/qscintilla/qscintilla_1.65-gpl-1.6.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/qscintilla/qscintilla_1.65-gpl-1.6.bb b/packages/qscintilla/qscintilla_1.65-gpl-1.6.bb
new file mode 100644
index 0000000000..a313d8c73e
--- /dev/null
+++ b/packages/qscintilla/qscintilla_1.65-gpl-1.6.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Qt/Embedded bindings for the Scintilla source code editor component"
+SECTION = "opie/libs"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/qscintilla-${PV}_zaurus.tar.gz"
+
+S = "${WORKDIR}/qscintilla-${PV}/qt"
+
+inherit opie
+
+QMAKE_PROFILES = "qscintilla.pro"
+
+EXTRA_QMAKEVARS_POST += " CONFIG-=thread INCLUDEPATH+=${S}/patches DEFINES+=ZPATCH \
+ HEADERS-=qextscintillaprinter.h \
+ SOURCES-=qextscintillaprinter.cpp \
+ SOURCES+=patches/qsettings.cpp \
+ SOURCES+=patches/qsettings_unix.cpp \
+ HEADERS+=patches/qsettings.h"
+
+PARALLEL_MAKE = ""
+
+
+do_stage() {
+ install -m 0644 qextscintilla*.h ${STAGING_INCDIR}/
+ oe_libinstall -so libqscintilla ${STAGING_LIBDIR}
+}