aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qt4
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-02-27 13:51:14 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2009-02-27 13:51:14 +0100
commit97547278b07476ec55e1c82df63628cdf35a56b5 (patch)
treed011ff285cba66a918dff3c89130ce9d3a64e823 /packages/qt4
parent8aaaf613397aa4a2de6f51ea9185358c26b52f8c (diff)
downloadopenembedded-97547278b07476ec55e1c82df63628cdf35a56b5.tar.gz
qt4: split qt-embedded and qtopia-core
Diffstat (limited to 'packages/qt4')
-rw-r--r--packages/qt4/qt-embedded_4.4.3.bb40
-rw-r--r--packages/qt4/qtopia-core.inc43
-rw-r--r--packages/qt4/qtopia-core_4.3.3.bb44
3 files changed, 71 insertions, 56 deletions
diff --git a/packages/qt4/qt-embedded_4.4.3.bb b/packages/qt4/qt-embedded_4.4.3.bb
index 18cf3cbc44..088300fda5 100644
--- a/packages/qt4/qt-embedded_4.4.3.bb
+++ b/packages/qt4/qt-embedded_4.4.3.bb
@@ -1,6 +1,10 @@
-require qtopia-core.inc
-
-PR = "r5"
+SUMMARY = "Qt is a versatile cross-platform application framework -- this is the embedded version."
+SECTION = "libs"
+LICENSE = "GPL"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+DEPENDS += "tslib"
+PR = "r6"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
file://qconfig-oe.h \
@@ -8,23 +12,37 @@ SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${
file://0003-no-tools.patch;patch=1 \
file://0004-no-qmake.patch;patch=1 \
file://0005-fix-mkspecs.patch;patch=1 \
- file://qt-lib-infix.patch;patch=1 \
- file://build-tools.patch;patch=1"
-S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
-
-SRC_URI += " \
file://0006-freetype-host-includes.patch;patch=1 \
file://0007-openssl-host-includes.patch;patch=1 \
+ file://qt-lib-infix.patch;patch=1 \
+ file://build-tools.patch;patch=1 \
file://support-2bpp.patch;patch=1 \
# file://allow-configure-plugins.patch;patch=1 \
-"
+ "
+S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
QT_CONFIG_FLAGS += " \
+ -nomake demos -nomake examples -nomake tools -qtlibinfix E\
+ -embedded ${QT_ARCH} \
+ -qt-decoration-styled -plugin-decoration-default -plugin-decoration-windows \
+ -plugin-gfx-transformed -plugin-gfx-qvfb -plugin-gfx-vnc\
+ -plugin-mouse-tslib -qt-mouse-pc -qt-mouse-qvfb\
+ -qt-kbd-tty -qt-kbd-usb -qt-kbd-qvfb\
-webkit \
-DQT_KEYPAD_NAVIGATION \
- "
+ "
+
+do_configure_prepend() {
+ cp ${WORKDIR}/qconfig-oe.h ${S}/src/corelib/global
+}
QT_BASE_NAME = "qt-embedded"
QT_BASE_LIB = "libqt-embedded"
+QT_DIR_NAME = "qtopia"
+QT_LIBINFIX="E"
+require qt_depends.inc
+require qt_configuration.inc
+require qt_packaging.inc
+require qt_staging.inc
-
+inherit qtopia4core
diff --git a/packages/qt4/qtopia-core.inc b/packages/qt4/qtopia-core.inc
deleted file mode 100644
index eab7e1b3e1..0000000000
--- a/packages/qt4/qtopia-core.inc
+++ /dev/null
@@ -1,43 +0,0 @@
-SUMMARY = "Qt is a versatile cross-platform application framework -- this is the QtopiaCore/Embedded version."
-SECTION = "libs"
-LICENSE = "GPL"
-PRIORITY = "optional"
-HOMEPAGE = "http://www.trolltech.com"
-DEPENDS += "tslib"
-PR = "r3"
-
-SRC_URI = "ftp://ftp.trolltech.com/qt/source/qtopia-core-opensource-src-${PV}.tar.gz \
- file://qconfig-oe.h \
- file://0001-cross-compile.patch;patch=1 \
- file://0003-no-tools.patch;patch=1 \
- file://0004-no-qmake.patch;patch=1 \
- file://0005-fix-mkspecs.patch;patch=1 \
- file://build-tools.patch;patch=1"
-S = "${WORKDIR}/qtopia-core-opensource-src-${PV}"
-
-
-QT_CONFIG_FLAGS += " \
- -nomake demos -nomake examples -nomake tools -qtlibinfix E\
- -embedded ${QT_ARCH} \
- -qt-decoration-styled -plugin-decoration-default -plugin-decoration-windows \
- -plugin-gfx-transformed -plugin-gfx-qvfb -plugin-gfx-vnc\
- -plugin-mouse-tslib -qt-mouse-pc -qt-mouse-qvfb\
- -qt-kbd-tty -qt-kbd-usb -qt-kbd-qvfb\
- ${QT_QCONFIG} \
- "
-
-do_configure_prepend() {
- cp ${WORKDIR}/qconfig-oe.h ${S}/src/corelib/global
-}
-
-QT_QCONFIG = ""
-QT_BASE_NAME = "qtopiacore"
-QT_BASE_LIB = "libqtopiacore"
-QT_DIR_NAME = "qtopia"
-QT_LIBINFIX="E"
-require qt_depends.inc
-require qt_configuration.inc
-require qt_packaging.inc
-require qt_staging.inc
-
-inherit qtopia4core
diff --git a/packages/qt4/qtopia-core_4.3.3.bb b/packages/qt4/qtopia-core_4.3.3.bb
index 40ec78ef04..7888a8e7d3 100644
--- a/packages/qt4/qtopia-core_4.3.3.bb
+++ b/packages/qt4/qtopia-core_4.3.3.bb
@@ -1,6 +1,46 @@
-require qtopia-core.inc
-SRC_URI += " \
+SUMMARY = "Qt is a versatile cross-platform application framework -- this is the embedded version."
+SECTION = "libs"
+LICENSE = "GPL"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+DEPENDS += "tslib"
+PR = "r4"
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qtopia-core-opensource-src-${PV}.tar.gz \
+ file://qconfig-oe.h \
+ file://0001-cross-compile.patch;patch=1 \
+ file://0003-no-tools.patch;patch=1 \
+ file://0004-no-qmake.patch;patch=1 \
+ file://0005-fix-mkspecs.patch;patch=1 \
+ file://build-tools.patch;patch=1 \
file://0006-freetype-host-includes.patch;patch=1 \
file://0007-openssl-host-includes.patch;patch=1 \
file://0008-backport-qt-lib-infix.patch;patch=1 \
file://allow-configure-plugins.patch;patch=1 "
+S = "${WORKDIR}/qtopia-core-opensource-src-${PV}"
+
+QT_CONFIG_FLAGS += " \
+ -nomake demos -nomake examples -nomake tools -qtlibinfix E\
+ -embedded ${QT_ARCH} \
+ -qt-decoration-styled -plugin-decoration-default -plugin-decoration-windows \
+ -plugin-gfx-transformed -plugin-gfx-qvfb -plugin-gfx-vnc\
+ -plugin-mouse-tslib -qt-mouse-pc -qt-mouse-qvfb\
+ -qt-kbd-tty -qt-kbd-usb -qt-kbd-qvfb\
+ ${QT_QCONFIG} \
+ "
+
+do_configure_prepend() {
+ cp ${WORKDIR}/qconfig-oe.h ${S}/src/corelib/global
+}
+
+QT_QCONFIG = ""
+QT_BASE_NAME = "qtopiacore"
+QT_BASE_LIB = "libqtopiacore"
+QT_DIR_NAME = "qtopia"
+QT_LIBINFIX="E"
+require qt_depends.inc
+require qt_configuration.inc
+require qt_packaging.inc
+require qt_staging.inc
+
+inherit qtopia4core