aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qte
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-03-19 01:36:30 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-19 01:36:30 +0000
commitdacf6b8afe4dfec74a08e9dbcccb65c02fa0bfb7 (patch)
treee6d5f2fe9720e443ba84e22a74198cbc222da194 /packages/qte
parent93808a4dba2d26e2915aa2d18ee62a74fde9eb08 (diff)
downloadopenembedded-dacf6b8afe4dfec74a08e9dbcccb65c02fa0bfb7.tar.gz
qt/embedded 2.3.10: add gcc4 patch to make it compile :)
Diffstat (limited to 'packages/qte')
-rw-r--r--packages/qte/qte-2.3.10/gcc4.patch16
-rw-r--r--packages/qte/qte_2.3.10.bb3
2 files changed, 18 insertions, 1 deletions
diff --git a/packages/qte/qte-2.3.10/gcc4.patch b/packages/qte/qte-2.3.10/gcc4.patch
new file mode 100644
index 0000000000..550effd7ba
--- /dev/null
+++ b/packages/qte/qte-2.3.10/gcc4.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- qt-2.3.10/src/tools/qvaluestack.h~gcc4 2005-01-23 15:00:47.000000000 +0100
++++ qt-2.3.10/src/tools/qvaluestack.h 2006-03-19 02:32:56.000000000 +0100
+@@ -54,7 +54,7 @@
+ {
+ T elem( this->last() );
+ if ( !this->isEmpty() )
+- remove( this->fromLast() );
++ this->remove( this->fromLast() );
+ return elem;
+ }
+ T& top() { return this->last(); }
diff --git a/packages/qte/qte_2.3.10.bb b/packages/qte/qte_2.3.10.bb
index 363f8df00c..fc03ca216b 100644
--- a/packages/qte/qte_2.3.10.bb
+++ b/packages/qte/qte_2.3.10.bb
@@ -8,7 +8,7 @@ DEPENDS = "zlib libpng jpeg tslib uicmoc-native"
DEPENDS_mnci = "zlib libpng jpeg uicmoc-native"
DEPENDS_append_c7x0 = " sharp-aticore-oss"
PROVIDES = "virtual/qte virtual/libqte2"
-PR = "r29"
+PR = "r30"
SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz;md5sum=af7ad30113afc500cab7f5b2f4dec0d7 \
file://qpe.patch;patch=1 \
@@ -16,6 +16,7 @@ SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz;m
file://daemonize.patch;patch=1 \
file://no-moc.patch;patch=1 \
file://gcc3.patch;patch=1 \
+ file://gcc4.patch;patch=1 \
file://c700-hardware.patch;patch=1 \
file://encoding.patch;patch=1 \
file://fix-qgfxraster.patch;patch=1 \