aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qte
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-07-02 11:06:08 +0000
committerKoen Kooi <koen@openembedded.org>2007-07-02 11:06:08 +0000
commit0a74111ed0ebc31a94a2580e7b55cc8aeb5a5b97 (patch)
tree547967661f64e7f2606587ba16826f57313e4133 /packages/qte
parentd8022111c8787f65ce252430c05368074b3f490e (diff)
downloadopenembedded-0a74111ed0ebc31a94a2580e7b55cc8aeb5a5b97.tar.gz
qtopia-core: fix packaging
Diffstat (limited to 'packages/qte')
-rw-r--r--packages/qte/qtopia-core_4.2.0.bb121
1 files changed, 81 insertions, 40 deletions
diff --git a/packages/qte/qtopia-core_4.2.0.bb b/packages/qte/qtopia-core_4.2.0.bb
index ecb5978fed..ab07ecf35d 100644
--- a/packages/qte/qtopia-core_4.2.0.bb
+++ b/packages/qte/qtopia-core_4.2.0.bb
@@ -3,16 +3,15 @@ SECTION = "libs"
LICENSE = "GPL"
PRIORITY = "optional"
HOMEPAGE = "http://www.trolltech.com"
-DEPENDS = "glib-2.0 dbus-glib tslib"
-PR = "r1"
+DEPENDS = "glib-2.0 freetype dbus-glib tslib"
+
+PR = "r2"
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qtopia-core-opensource-src-${PV}.tar.gz \
file://linux-oe-qmake.conf"
S = "${WORKDIR}/qtopia-core-opensource-src-${PV}"
-PARALLEL_MAKE = ""
-
inherit pkgconfig
# I'm not sure about the globals QTDIR and QTOPIADIR, or if they're even
@@ -33,6 +32,7 @@ export QTOPIADIR = "${S}"
# Qmake gets confused by environment variables, as it builds both HOST
# and TARGET objects. The correct compiler settings come from the mkspec
# and are set with the OE_QMAKE_ variables
+PARALLEL_MAKE = ""
EXTRA_OEMAKE = " MAKEFLAGS= "
# This stuff could also be done by inheriting qmake, but I didn't want to
@@ -48,7 +48,7 @@ export OE_QMAKE_LDFLAGS="${LDFLAGS}"
export OE_QMAKE_LINK="${CXX}"
export OE_QMAKE_AR="${AR}"
export OE_QMAKE_RANLIB="${RANLIB}"
-export OE_QMAKE_STRIP="${STRIP}"
+export OE_QMAKE_STRIP="echo"
export OE_QMAKE_RPATH="-Wl,-rpath-link,"
export OE_QMAKE_INCDIR_QT="${QTDIR}/include"
export OE_QMAKE_LIBDIR_QT="${QTDIR}/lib"
@@ -65,37 +65,10 @@ QT_ENDIAN = "-little-endian"
# frequently, only for testing maybe. Feel free to change and to package
# them separately.
QT_CONFIG_FLAGS = "-release \
- -no-cups -no-accessibility -no-freetype \
+ -no-cups -no-accessibility \
-nomake demos -nomake examples -nomake tools \
-qt-mouse-tslib"
-# We might want to package all the libraries separately, so you can really
-# fine-tune what to install. This is e.g. done in qt4-x11-free_4.1.2.bb.
-# What should these packages be called? I'm tempted to call them the same
-# as in qt4 version, as the API is supposed to be compatible, e.g.
-# libqtcore4 and libqtgui4. This will however conflict if you have QT and
-# Qtopia, but this is something you don't want anyway, I guess.
-# Another solution is making virtual/libqtfoo4, and DEPENDing on that one
-# and let both the PACKAGES in QT and Qtopia PROVIDE these. The packages
-# themselves could then be called libqtopiafoo4.
-# I'll postpone this discussion by not making separate Qtopia packages.
-
-# Also, I don't package the plugins and translations atm, I don't use them
-# and I don't feel like thinking about a sensible separation.
-
-# PACKAGES += "libqtopiacore4 libqtopiagui4 ..."
-# RDEPENDS_${PN} += "..."
-
-# The default included fonts are around 75MB and consist of a number of
-# FreeType-renderable fonts as well as QPF (Qtopia Prerendered Fonts).
-# As FreeType is generally slow on embedded platforms, and 75MB is
-# quite huge, we downsize the fonts dir in the do_install. I've decided
-# to include only the QPF (Helvetica and Fixed), amounting to 500KB. This
-# also results in tremendously faster application startup time.
-# You might want to package the fonts separately, or include all fonts in
-# a separate package.
-FILES_${PN} += " /usr/lib/fonts/* "
-
do_configure() {
# Install the OE build templates (something which might be done
# by inheriting qmake)
@@ -141,16 +114,84 @@ do_install() {
# These are host binaries, we should only use them in staging
rm -rf ${D}/${bindir}
rm -rf ${D}/${datadir}/mkspecs
-
- # Downsize on the fonts, we're only packaging the Helvetica and
- # Fixed, only the QPF versions. Maybe later add an additional
- # package for all fonts.
- rm -f ${D}/${libdir}/fonts/*
- cp -a ${S}/lib/fonts/helvetica*qpf ${D}/${libdir}/fonts
- cp -a ${S}/lib/fonts/fixed*qpf ${D}/${libdir}/fonts
+
touch ${D}/${libdir}/fonts/fontdir
+
+ #TT is still new to pkgconfig, so fix it up
+ install -d ${D}${libdir}/pkgconfig
+ mv ${D}/${libdir}/*.pc ${D}${libdir}/pkgconfig/
}
+# We might want to package all the libraries separately, so you can really
+# fine-tune what to install. This is e.g. done in qt4-x11-free_4.1.2.bb.
+# What should these packages be called? I'm tempted to call them the same
+# as in qt4 version, as the API is supposed to be compatible, e.g.
+# libqtcore4 and libqtgui4. This will however conflict if you have QT and
+# Qtopia, but this is something you don't want anyway, I guess.
+# Another solution is making virtual/libqtfoo4, and DEPENDing on that one
+# and let both the PACKAGES in QT and Qtopia PROVIDE these. The packages
+# themselves could then be called libqtopiafoo4.
+# I'll postpone this discussion by not making separate Qtopia packages.
+
+# Also, I don't package the plugins and translations atm, I don't use them
+# and I don't feel like thinking about a sensible separation.
+
+PACKAGES =+ " libqtcore libqtcore-dev libqtcore-dbg \
+ libqtxml libqtxml-dev libqtxml-dbg \
+ libqtgui libqtgui-dev libqtgui-dbg \
+ libqtsql libqtsql-dev libqtsql-dbg \
+ libqtnetwork libqtnetwork-dev libqtnetwork-dbg \
+ libqtsvg libqtsvg-dev libqtsvg-dbg \
+ libqt3support libqt3support-dev libqt3support-dbg \
+ qtopia-core-plugins qtopia-core-plugins-dbg\
+ "
+
+PACKAGES += " ${PN}-fonts "
+
+# The default included fonts are around 75MB and consist of a number of
+# FreeType-renderable fonts as well as QPF (Qtopia Prerendered Fonts).
+# As FreeType is generally slow on embedded platforms, and 75MB is
+# quite huge, we downsize the fonts dir in the do_install. I've decided
+# to include only the QPF (Helvetica and Fixed), amounting to 500KB. This
+# also results in tremendously faster application startup time.
+FILES_libqtcore += " ${libdir}/fonts/helvetic* ${libdir}/fonts/fixed* ${D}/${libdir}/fonts/fontdir"
+FILES_${PN}-fonts = "${libdir}/fonts"
+
+FILES_qtopia-core-plugins += "${datadir}/qtopia/plugins/*/*.so"
+FILES_qtopia-core-plugins-dbg += "${datadir}/qtopia/plugins/*/.debug/*.so"
+
+FILES_libqtcore += "${libdir}/libQtCore.so.*"
+FILES_libqtxml += "${libdir}/libQtXml.so.*"
+FILES_libqtgui += "${libdir}/libQtGui.so.*"
+FILES_libqtsql += "${libdir}/libQtSql.so.*"
+FILES_libqtnetwork += "${libdir}/libQtNetwork.so.*"
+FILES_libqtsvg += "${libdir}/libQtSvg.so.*"
+FILES_libqt3support += "${libdir}/libQt3Support.so.*"
+
+FILES_libqtcore-dev += "${libdir}/*QtCore.*"
+FILES_libqtxml-dev += "${libdir}/*QtXml.*"
+FILES_libqtgui-dev += "${libdir}/*QtGui.*"
+FILES_libqtsql-dev += "${libdir}/*QtSql.*"
+FILES_libqtnetwork-dev += "${libdir}/*QtNetwork.*"
+FILES_libqtsvg-dev += "${libdir}/*QtSvg.*"
+FILES_libqt3support-dev += "${libdir}/*Qt3Support.*"
+
+FILES_libqtcore-dbg += "${libdir}/.debug/libQtCore*"
+FILES_libqtxml-dbg += "${libdir}/.debug/libQtXml*"
+FILES_libqtgui-dbg += "${libdir}/.debug/libQtGui*"
+FILES_libqtsql-dbg += "${libdir}/.debug/libQtSql*"
+FILES_libqtnetwork-dbg += "${libdir}/.debug/libQtNetwork*"
+FILES_libqtsvg-dbg += "${libdir}/.debug/libQtSvg*"
+FILES_libqt3support-dbg += "${libdir}/.debug/libQt3Support*"
+
+
+python populate_packages_prepend() {
+ translationdir = bb.data.expand('${datadir}/qtopia/translations/', d)
+ do_split_packages(d, translationdir, '^qt_(.*)\.qm$', 'qtopia-translation-%s', 'Qtopia translation for %s', extra_depends='' )
+}
+
+
+
STAGE_TEMP = "${WORKDIR}/temp-staging"
do_stage() {
rm -rf ${STAGE_TEMP}