aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qtnx
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-09-08 18:52:35 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-09-08 18:52:35 +0000
commitad97d12cc7b2d1da6bc6b0d56f3e3a559ad967e1 (patch)
treefc9636547907d0338686571ce05adb7e6c7006ec /packages/qtnx
parent0d26f4acd6eacf6b1e7c9c09f1ba1ef334c50dc9 (diff)
downloadopenembedded-ad97d12cc7b2d1da6bc6b0d56f3e3a559ad967e1.tar.gz
qtnx: split up for qtx11 vs. qte/qtopia
* do the same like qsvn and let the image/distribution decide which package should be in * bump PR
Diffstat (limited to 'packages/qtnx')
-rw-r--r--packages/qtnx/qtnx-qte_0.9.bb2
-rw-r--r--packages/qtnx/qtnx.inc31
-rw-r--r--packages/qtnx/qtnx_0.9.bb36
3 files changed, 35 insertions, 34 deletions
diff --git a/packages/qtnx/qtnx-qte_0.9.bb b/packages/qtnx/qtnx-qte_0.9.bb
new file mode 100644
index 0000000000..998666b276
--- /dev/null
+++ b/packages/qtnx/qtnx-qte_0.9.bb
@@ -0,0 +1,2 @@
+require qtnx.inc
+inherit qtopia4core
diff --git a/packages/qtnx/qtnx.inc b/packages/qtnx/qtnx.inc
new file mode 100644
index 0000000000..b20339001e
--- /dev/null
+++ b/packages/qtnx/qtnx.inc
@@ -0,0 +1,31 @@
+DESCRIPTION = "This a the freesource nx client, build with qt"
+HOMEPAGE = "http://freenx.berlios.de/"
+SECTION = "libs"
+LICENSE = "GPL"
+PR = "r1"
+
+DEPENDS = "libnxcl"
+
+SRC_URI = "http://download.berlios.de/freenx/freenx-client-${PV}.tar.bz2 \
+ file://pro.patch;patch=1 \
+ file://id-path.patch;patch=1 \
+ file://scroll.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/freenx-client-${PV}/qtnx"
+
+FILES_${PN} += ${datadir}/id.key
+
+do_configure_prepend () {
+
+ rm ${S}/qtnxwin32.pro
+
+}
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -s -m 0755 qtnx ${D}${bindir}/
+ install -d ${D}${datadir}/
+ install -m 0644 id.key ${D}${datadir}/
+}
+
diff --git a/packages/qtnx/qtnx_0.9.bb b/packages/qtnx/qtnx_0.9.bb
index d0ed565b36..f4e045d60d 100644
--- a/packages/qtnx/qtnx_0.9.bb
+++ b/packages/qtnx/qtnx_0.9.bb
@@ -1,34 +1,2 @@
-DESCRIPTION = "This a the freesource nx client, build with qt"
-HOMEPAGE = "http://freenx.berlios.de/"
-SECTION = "libs"
-LICENSE = "GPL"
-PR = "r0"
-
-DEPENDS = "libnxcl"
-
-SRC_URI = "http://download.berlios.de/freenx/freenx-client-${PV}.tar.bz2 \
- file://pro.patch;patch=1 \
- file://id-path.patch;patch=1 \
- file://scroll.patch;patch=1 \
- "
-
-S = "${WORKDIR}/freenx-client-${PV}/qtnx"
-
-inherit qtopia4core
-
-
-FILES_${PN} += ${datadir}/id.key
-
-do_configure_prepend () {
-
- rm ${S}/qtnxwin32.pro
-
-}
-
-do_install () {
- install -d ${D}${bindir}/
- install -s -m 0755 qtnx ${D}${bindir}/
- install -d ${D}${datadir}/
- install -m 0644 id.key ${D}${datadir}/
-}
-
+require qtnx.inc
+inherit qt4x11