aboutsummaryrefslogtreecommitdiffstats
path: root/packages/quake
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-08-06 12:31:47 +0000
committerKoen Kooi <koen@openembedded.org>2008-08-06 12:31:47 +0000
commit0f407424b04fea1750ac10a358c1566c0a56ed4f (patch)
treee12f56458f0851d0a3a67f51a4f9e972b2b182ec /packages/quake
parentbf473b351fb6cc2fc7a5e221c18b4825a3222544 (diff)
downloadopenembedded-0f407424b04fea1750ac10a358c1566c0a56ed4f.tar.gz
quetoo: uglify recipe a bit more so that it compiles with gcc4.3 and libtool 2.x
Diffstat (limited to 'packages/quake')
-rw-r--r--packages/quake/quetoo_0.6.1.bb17
1 files changed, 14 insertions, 3 deletions
diff --git a/packages/quake/quetoo_0.6.1.bb b/packages/quake/quetoo_0.6.1.bb
index 931b002d1c..33a7075799 100644
--- a/packages/quake/quetoo_0.6.1.bb
+++ b/packages/quake/quetoo_0.6.1.bb
@@ -8,13 +8,24 @@ inherit autotools pkgconfig
EXTRA_OECONF = "\
- --with-sdl \
+ --with-games=baseq2 \
+ --with-sdl \
--with-zlib \
"
do_configure() {
- gnu-configize
- libtoolize --force
+ for i in ctf qmass vanctf ; do
+ mkdir -p ${S}/data/$i/sound
+ mkdir -p ${S}/data/$i/maps
+ mkdir -p ${S}/src/$i
+ touch ${S}/data/$i/Makefile.in
+ touch ${S}/data/$i/sound/Makefile.in
+ touch ${S}/data/$i/maps/Makefile.in
+ touch ${S}/src/$i/Makefile.in
+ done
+
+ sed -i -e s:-Werror::g ${S}/configure
+ gnu-configize --force
oe_runconf
rm config.log
}