aboutsummaryrefslogtreecommitdiffstats
path: root/packages/quake
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-09-08 17:48:28 +0000
committerKoen Kooi <koen@openembedded.org>2008-09-08 17:48:28 +0000
commit2c078b10e276f29a5b74568c631b435fbb69b164 (patch)
tree1ed56e7c2928550c7121423fbbecc0b6307020be /packages/quake
parentbaf75064c690dec8cc0a77655230ab4ec051e308 (diff)
downloadopenembedded-2c078b10e276f29a5b74568c631b435fbb69b164.tar.gz
ioquake3: add 1.32
Diffstat (limited to 'packages/quake')
-rw-r--r--packages/quake/ioquake3_svn.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/quake/ioquake3_svn.bb b/packages/quake/ioquake3_svn.bb
new file mode 100644
index 0000000000..6d79ff1b23
--- /dev/null
+++ b/packages/quake/ioquake3_svn.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "ioquake3 (or ioq3 for short,) aims to build upon id Software's Quake 3 source code release. "
+DEPENDS = "virtual/libsdl"
+LICENSE = "GPLv2"
+
+PV = "1.34+svnr${SRCREV}"
+SRCREV="1470"
+SRC_URI = "svn://svn.icculus.org/quake3/;module=trunk"
+
+S = "${WORKDIR}/trunk"
+
+export COMPILE_PLATFORM = "linux"
+export COMPILE_ARCH = "${TARGET_ARCH}"
+export USE_OPENAL=0
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -d ${D}/${datadir}/games/quake3/baseq3
+ install -m 0755 ${S}/build/release-${COMPILE_PLATFORM}-${COMPILE_ARCH}/*.${COMPILE_ARCH} ${D}/${bindir}
+ cp -pPR ${S}/build/release-${COMPILE_PLATFORM}-${COMPILE_ARCH}/baseq3/*.so ${D}/${datadir}/games/quake3/baseq3/
+}
+
+
+FILES_${PN}-dbg += "${datadir}/games/quake3/baseq3/.debug"
+FILES_${PN} += "${datadir}/games/quake3/baseq3/"