aboutsummaryrefslogtreecommitdiffstats
path: root/packages/quake
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-09-09 10:49:00 +0000
committerKoen Kooi <koen@openembedded.org>2008-09-09 10:49:00 +0000
commit9e1c12964cfef801b58a3711578918d5869fb2f8 (patch)
treec6349b077aacb70319977676fa3ddf54c198d25e /packages/quake
parentf6f94add26d5da9f6c9296bbe1c20f8856e558da (diff)
downloadopenembedded-9e1c12964cfef801b58a3711578918d5869fb2f8.tar.gz
quake2: add quake2 from icculus.org
Diffstat (limited to 'packages/quake')
-rw-r--r--packages/quake/quake2/.mtn2git_empty0
-rw-r--r--packages/quake/quake2/quake2-arm.patch32
-rw-r--r--packages/quake/quake2_svn.bb39
3 files changed, 71 insertions, 0 deletions
diff --git a/packages/quake/quake2/.mtn2git_empty b/packages/quake/quake2/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/quake/quake2/.mtn2git_empty
diff --git a/packages/quake/quake2/quake2-arm.patch b/packages/quake/quake2/quake2-arm.patch
new file mode 100644
index 0000000000..02b3cb2eae
--- /dev/null
+++ b/packages/quake/quake2/quake2-arm.patch
@@ -0,0 +1,32 @@
+--- /tmp/sys_linux.c 2008-09-09 11:50:06.000000000 +0200
++++ trunk/src/linux/sys_linux.c 2008-09-09 11:48:06.113198000 +0200
+@@ -225,6 +225,8 @@
+ const char *gamename = "gameppc.so";
+ #elif defined __sparc__
+ const char *gamename = "gamesparc.so";
++#elif defined __arm__
++ const char *gamename = "gamearm.so";
+ #else
+ #error Unknown arch
+ #endif
+--- /tmp/Makefile 2008-09-09 11:52:05.000000000 +0200
++++ trunk/Makefile 2008-09-09 11:53:26.543198000 +0200
+@@ -60,18 +60,6 @@
+ # this nice line comes from the linux kernel makefile
+ ARCH := $(shell uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc/ -e s/sparc64/sparc/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/alpha/axp/)
+
+-ifneq ($(ARCH),x86_64)
+-ifneq ($(ARCH),i386)
+-ifneq ($(ARCH),axp)
+-ifneq ($(ARCH),ppc)
+-ifneq ($(ARCH),sparc)
+-$(error arch $(ARCH) is currently not supported)
+-endif
+-endif
+-endif
+-endif
+-endif
+-
+ CC=gcc
+
+ ifndef OPT_CFLAGS
diff --git a/packages/quake/quake2_svn.bb b/packages/quake/quake2_svn.bb
new file mode 100644
index 0000000000..a90b3183bc
--- /dev/null
+++ b/packages/quake/quake2_svn.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Icculus.org quake2 engine"
+LICENSE = "GPL"
+
+DEPENDS = "libsdl-x11"
+
+SRCREV = "205"
+PV = "0.16.1+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.icculus.org/quake2/;module=trunk \
+ file://quake2-arm.patch;patch=1"
+
+S = "${WORKDIR}/trunk"
+
+export BUILD_SDLQUAKE2=YES
+export OSTYPE=Linux
+export ARCH=${TARGET_ARCH}
+export BASE_CFLAGS="${TARGET_CC_ARCH} -Wall -pipe -Dstricmp=strcasecmp"
+export OPT_CFLAGS="-O3 -ffast-math -funroll-loops -fomit-frame-pointer -fexpensive-optimizations"
+
+do_compile() {
+ sed -i -e s:=gcc:=${TARGET_PREFIX}gcc:g Makefile
+ oe_runmake -e
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ echo -e "#!/bin/sh \ncd ${libdir}/quake2 && ./quake2 \$@ \n" > ${D}/${bindir}/quake2
+
+ ( cd ${S}/debug${TARGET_ARCH} ; ln -sf gamei386.so game${TARGET_ARCH}.so )
+ install -d ${D}/${libdir}/quake2/baseq2/ctf
+ install -m 0755 ${S}/debug${TARGET_ARCH}/game${TARGET_ARCH}.so ${D}/${libdir}/quake2/baseq2
+ install -m 0755 ${S}/debug${TARGET_ARCH}/ref*.so ${D}/${libdir}/quake2
+ install -m 0755 ${S}/debug${TARGET_ARCH}/ctf/*.so ${D}/${libdir}/quake2/baseq2/ctf
+ install -m 0755 ${S}/debug${TARGET_ARCH}/quake2 ${D}/${libdir}/quake2
+}
+
+FILES_${PN} += "${libdir}"
+FILES_${PN}-dbg += "${libdir}/quake2/baseq2/.debug ${libdir}/quake2/baseq2/ctf/.debug"
+