aboutsummaryrefslogtreecommitdiffstats
path: root/packages/quake
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/quake
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/quake')
-rw-r--r--packages/quake/.mtn2git_empty0
-rw-r--r--packages/quake/files/.mtn2git_empty0
-rw-r--r--packages/quake/files/Makefile.patch10
-rw-r--r--packages/quake/files/host.c.patch29
-rw-r--r--packages/quake/files/vid_sdl.c.patch11
5 files changed, 50 insertions, 0 deletions
diff --git a/packages/quake/.mtn2git_empty b/packages/quake/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/quake/.mtn2git_empty
diff --git a/packages/quake/files/.mtn2git_empty b/packages/quake/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/quake/files/.mtn2git_empty
diff --git a/packages/quake/files/Makefile.patch b/packages/quake/files/Makefile.patch
index e69de29bb2..ba2c6cf997 100644
--- a/packages/quake/files/Makefile.patch
+++ b/packages/quake/files/Makefile.patch
@@ -0,0 +1,10 @@
+--- quake1src/Makefile~ 2004-10-07 14:29:11.000000000 +0100
++++ quake1src/Makefile 2005-05-06 16:04:50.808451944 +0100
+@@ -97,7 +92,6 @@
+ r_misc.o \
+ snd_mix.o \
+ wad.o \
+- cd_sdl.o \
+ crc.o \
+ d_sprite.o \
+ model.o \
diff --git a/packages/quake/files/host.c.patch b/packages/quake/files/host.c.patch
index e69de29bb2..e5e6457241 100644
--- a/packages/quake/files/host.c.patch
+++ b/packages/quake/files/host.c.patch
@@ -0,0 +1,29 @@
+--- quake1src/host.c~ 2003-09-09 13:59:53.000000000 +0100
++++ quake1src/host.c 2005-05-06 16:13:50.193452960 +0100
+@@ -874,7 +874,7 @@
+ else
+ S_Update (vec3_origin, vec3_origin, vec3_origin, vec3_origin);
+
+- CDAudio_Update();
++// CDAudio_Update();
+
+ if (host_speeds.value)
+ {
+@@ -1074,7 +1074,7 @@
+ #endif
+
+ #endif // _WIN32
+- CDAudio_Init ();
++// CDAudio_Init ();
+ Sbar_Init ();
+ CL_Init ();
+ #ifdef _WIN32 // on non win32, mouse comes before video for security reasons
+@@ -1117,7 +1117,7 @@
+
+ Host_WriteConfiguration ();
+
+- CDAudio_Shutdown ();
++// CDAudio_Shutdown ();
+ NET_Shutdown ();
+ S_Shutdown();
+ IN_Shutdown ();
diff --git a/packages/quake/files/vid_sdl.c.patch b/packages/quake/files/vid_sdl.c.patch
index e69de29bb2..17d58d8164 100644
--- a/packages/quake/files/vid_sdl.c.patch
+++ b/packages/quake/files/vid_sdl.c.patch
@@ -0,0 +1,11 @@
+--- quake1src/vid_sdl.c~ 2003-09-24 02:18:50.000000000 +0100
++++ quake1src/vid_sdl.c 2005-05-08 15:30:10.663089128 +0100
+@@ -59,7 +59,7 @@
+ Uint32 flags;
+
+ // Load the SDL library
+- if (SDL_Init(SDL_INIT_VIDEO|SDL_INIT_AUDIO|SDL_INIT_CDROM) < 0)
++ if (SDL_Init(SDL_INIT_VIDEO|SDL_INIT_AUDIO) < 0)
+ Sys_Error("VID: Couldn't load SDL: %s", SDL_GetError());
+
+ // Set up display mode (width and height)