aboutsummaryrefslogtreecommitdiffstats
path: root/packages/quake
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-06-06 13:09:19 +0000
committerKoen Kooi <koen@openembedded.org>2007-06-06 13:09:19 +0000
commitdf08ea5a36b5ea679f95da93042a2d3c0cf21bd9 (patch)
treebf2eb89375be7be7c64321293326c76ccf2bf1b5 /packages/quake
parent0d6e9946d54af11462806d8aa9a2b81e151c87ab (diff)
downloadopenembedded-df08ea5a36b5ea679f95da93042a2d3c0cf21bd9.tar.gz
quetoo: gpl quake2 engine focused on performance
Diffstat (limited to 'packages/quake')
-rw-r--r--packages/quake/quetoo_0.6.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/quake/quetoo_0.6.1.bb b/packages/quake/quetoo_0.6.1.bb
new file mode 100644
index 0000000000..9428f501f4
--- /dev/null
+++ b/packages/quake/quetoo_0.6.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Initially a fork of the Quake2Forge project, this engine aims to provide security and performance enhancements."
+LICENSE = "GPLv2"
+
+DEPENDS = "libsdl-x11 zlib mesa"
+SRC_URI = "http://tastyspleen.net/~jdolan/quetoo-${PV}-full.tar.bz2"
+
+inherit autotools pkgconfig
+
+
+EXTRA_OECONF = "\
+ --with-sdl \
+ --with-zlib \
+ "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+ rm config.log
+}
+
+do_install_append() {
+ mv ${D}${bindir}/${TARGET_PREFIX}quetoo ${D}${bindir}/quetoo
+}
+
+FILES_${PN}-dbg += "${libdir}/quetoo/baseq2/.debug"