aboutsummaryrefslogtreecommitdiffstats
path: root/packages/quake
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-05-09 09:39:51 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-05-09 09:39:51 +0000
commitfb6cfe3e6301bf8cd2e84c1b793c4e91bac1d6b6 (patch)
tree74c009937ca7476d37df32ff65ce20bdd086d623 /packages/quake
parent252375c3060241dec0504e64b638a908beafc718 (diff)
downloadopenembedded-fb6cfe3e6301bf8cd2e84c1b793c4e91bac1d6b6.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/05/09 11:18:43+02:00 utwente.nl!koen vid_sdl.c.patch: add missing file for quake1. 2005/05/09 11:06:03+02:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/05/09 11:05:50+02:00 uni-frankfurt.de!mickeyl upgrade quake1 courtesy Simon Pickering BKrev: 427f2fe7nHpzSdYXOmEPzyL3j101kg
Diffstat (limited to 'packages/quake')
-rw-r--r--packages/quake/files/cl_parse.c.patch42
-rw-r--r--packages/quake/files/vid_sdl.c.patch0
-rw-r--r--packages/quake/quake1_0.0.1.bb30
3 files changed, 72 insertions, 0 deletions
diff --git a/packages/quake/files/cl_parse.c.patch b/packages/quake/files/cl_parse.c.patch
index e69de29bb2..a233d608a4 100644
--- a/packages/quake/files/cl_parse.c.patch
+++ b/packages/quake/files/cl_parse.c.patch
@@ -0,0 +1,42 @@
+--- quake1src/cl_parse.c~ 2003-09-09 14:30:55.000000000 +0100
++++ quake1src/cl_parse.c 2005-05-06 16:02:13.228407752 +0100
+@@ -898,14 +898,14 @@
+
+ if (cl.paused)
+ {
+- CDAudio_Pause ();
++// CDAudio_Pause ();
+ #ifdef _WIN32
+ VID_HandlePause (true);
+ #endif
+ }
+ else
+ {
+- CDAudio_Resume ();
++// CDAudio_Resume ();
+ #ifdef _WIN32
+ VID_HandlePause (false);
+ #endif
+@@ -940,14 +940,14 @@
+ CL_ParseStaticSound ();
+ break;
+
+- case svc_cdtrack:
+- cl.cdtrack = MSG_ReadByte ();
+- cl.looptrack = MSG_ReadByte ();
+- if ( (cls.demoplayback || cls.demorecording) && (cls.forcetrack != -1) )
+- CDAudio_Play ((byte)cls.forcetrack, true);
+- else
+- CDAudio_Play ((byte)cl.cdtrack, true);
+- break;
++ case svc_cdtrack:
++ cl.cdtrack = MSG_ReadByte ();
++ cl.looptrack = MSG_ReadByte ();
++// if ( (cls.demoplayback || cls.demorecording) && (cls.forcetrack != -1) )
++// CDAudio_Play ((byte)cls.forcetrack, true);
++// else
++// CDAudio_Play ((byte)cl.cdtrack, true);
++ break;
+
+ case svc_intermission:
+ cl.intermission = 1;
diff --git a/packages/quake/files/vid_sdl.c.patch b/packages/quake/files/vid_sdl.c.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/quake/files/vid_sdl.c.patch
diff --git a/packages/quake/quake1_0.0.1.bb b/packages/quake/quake1_0.0.1.bb
index e69de29bb2..a0d858318f 100644
--- a/packages/quake/quake1_0.0.1.bb
+++ b/packages/quake/quake1_0.0.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Quake 1"
+SECTION = "x11/games"
+PRIORITY = "optional"
+DEPENDS = "libsdl-x11 libsdl-mixer libsdl-net zlib"
+MAINTAINER = "Simon Pickering <S.G.Pickering@bath.ac.uk>"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "http://mirror1.pdaXrom.org/rc9/src/quake1src.tar.bz2 \
+ http://mirror1.pdaxrom.org/source/src/pak0.tar.gz \
+ file://Makefile.patch;patch=1 \
+ file://cl_parse.c.patch;patch=1 \
+ file://vid_sdl.c.patch;patch=1 \
+ file://host.c.patch;patch=1"
+
+S = "${WORKDIR}/quake1src"
+
+inherit autotools
+
+EXTRA_OEMAKE = "-e"
+
+export CFLAG = "-DHAVE_ZLIB -DNO_DEBUG -finline-function"
+export CXXFLAGS = "-DHAVE_ZLIB -DNO_DEBUG -finline-function"
+export LIBS = "-L${STAGING_LIBDIR} -lz -lm -lX11 -lXext -lXau `${STAGING_BINDIR}/sdl-config --libs`"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 quake ${D}${bindir}
+}
+