aboutsummaryrefslogtreecommitdiffstats
path: root/packages/readline
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-09-29 12:09:17 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-29 12:09:17 +0000
commitfa83931aaa6c899c2400e3f47a3b693bb16f5fd8 (patch)
tree864e02e40fa1a5e2c02a6da543726f9b6b0ef6f6 /packages/readline
parent0809a79a7776069d1c58011b5eb294a5edfa9a56 (diff)
downloadopenembedded-fa83931aaa6c899c2400e3f47a3b693bb16f5fd8.tar.gz
ncurse, readline: use autotools_stage_all
Diffstat (limited to 'packages/readline')
-rw-r--r--packages/readline/readline_4.3.bb22
1 files changed, 5 insertions, 17 deletions
diff --git a/packages/readline/readline_4.3.bb b/packages/readline/readline_4.3.bb
index 234d697dfb..d0ff2a8d7c 100644
--- a/packages/readline/readline_4.3.bb
+++ b/packages/readline/readline_4.3.bb
@@ -4,12 +4,11 @@ additional functions to maintain a list of previously-entered command lines, to
lines, and perform csh-like history expansion on previous commands."
SECTION = "libs"
PRIORITY = "optional"
-MAINTAINER = "Greg Gilbert <greg@treke.net>"
LICENSE = "GPLv2"
DEPENDS += "ncurses"
RPROVIDES_${PN} += "readline"
LEAD_SONAME = "libreadline.so"
-PR = "r2"
+PR = "r3"
SRC_URI = "ftp://ftp.cwru.edu/pub/bash/readline-${PV}.tar.gz \
file://shlink-termcap.patch;patch=1 \
@@ -23,24 +22,13 @@ do_configure () {
autotools_do_configure
}
+do_stage() {
+ autotools_stage_all
+}
+
do_install () {
autotools_do_install
# Make install doesn't properly install these
oe_libinstall -so -C shlib libhistory ${D}${libdir}
oe_libinstall -so -C shlib libreadline ${D}${libdir}
}
-
-do_stage() {
- oe_libinstall -a libhistory ${STAGING_LIBDIR}
- oe_libinstall -a libreadline ${STAGING_LIBDIR}
- oe_libinstall -so -C shlib libhistory ${STAGING_LIBDIR}
- oe_libinstall -so -C shlib libreadline ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/readline
- for f in readline.h chardefs.h keymaps.h history.h tilde.h rlstdc.h \
- rlconf.h rltypedefs.h
- do
- install -m 0644 $f ${STAGING_INCDIR}/readline/
- done
-
-}