aboutsummaryrefslogtreecommitdiffstats
path: root/packages/readline
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-24 00:40:16 +0000
committerChris Larson <clarson@kergoth.com>2004-12-24 00:40:16 +0000
commitce2291e0bdc56906ee10662483721669c8b40973 (patch)
tree9dc702b66f226a5ed760e62318011ffaa13589d2 /packages/readline
parentcf68301c82c0e3609c7d9e0e62430d64e7243afd (diff)
downloadopenembedded-ce2291e0bdc56906ee10662483721669c8b40973.tar.gz
Merge oe-devel@oe-devel.bkbits.net:openembedded
into handhelds.org:/home/kergoth/code/openembedded 2004/12/23 18:40:15-06:00 ti.com!kergoth Fix up the readline build to depend on ncurses, apply a patch to link the shlib against the termcap lib (ncurses in this case), specify --with-curses, and set LEAD_SONAME. BKrev: 41cb6570gm9zLimj41VPpdR1lpaSwA
Diffstat (limited to 'packages/readline')
-rw-r--r--packages/readline/readline-4.3/shlink-termcap.patch0
-rw-r--r--packages/readline/readline_4.3.bb47
2 files changed, 47 insertions, 0 deletions
diff --git a/packages/readline/readline-4.3/shlink-termcap.patch b/packages/readline/readline-4.3/shlink-termcap.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/readline/readline-4.3/shlink-termcap.patch
diff --git a/packages/readline/readline_4.3.bb b/packages/readline/readline_4.3.bb
index e69de29bb2..8aba42f48c 100644
--- a/packages/readline/readline_4.3.bb
+++ b/packages/readline/readline_4.3.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
+command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \
+additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \
+lines, and perform csh-like history expansion on previous commands."
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Greg Gilbert <greg@treke.net>"
+LICENSE = "GPLv2"
+DEPENDS += "ncurses"
+RPROVIDES_${PN} += "readline"
+LEAD_SONAME = "libreadline.so"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.cwru.edu/pub/bash/readline-${PV}.tar.gz \
+ file://shlink-termcap.patch;patch=1 \
+ file://acinclude.m4"
+
+inherit autotools
+
+EXTRA_OECONF += "--with-curses"
+
+do_configure () {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+ autotools_do_configure
+}
+
+do_install () {
+ autotools_do_install
+ # Make install doesn't properly install these
+ oe_libinstall -so -C shlib libhistory ${D}/${libdir}
+ oe_libinstall -so -C shlib libreadline ${D}/${libdir}
+}
+
+do_stage() {
+ oe_libinstall -a libhistory ${STAGING_LIBDIR}
+ oe_libinstall -a libreadline ${STAGING_LIBDIR}
+ oe_libinstall -so -C shlib libhistory ${STAGING_LIBDIR}
+ oe_libinstall -so -C shlib libreadline ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/readline
+ for f in readline.h chardefs.h keymaps.h history.h tilde.h rlstdc.h \
+ rlconf.h rltypedefs.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/readline/
+ done
+
+}