aboutsummaryrefslogtreecommitdiffstats
path: root/packages/rhythmbox
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/rhythmbox
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/rhythmbox')
-rw-r--r--packages/rhythmbox/.mtn2git_empty0
-rw-r--r--packages/rhythmbox/rhythmbox/.mtn2git_empty0
-rw-r--r--packages/rhythmbox/rhythmbox/ogg.m4102
-rw-r--r--packages/rhythmbox/rhythmbox/vorbis.m4122
-rw-r--r--packages/rhythmbox/rhythmbox_0.8.5.bb28
-rw-r--r--packages/rhythmbox/rhythmbox_0.8.7.bb28
6 files changed, 280 insertions, 0 deletions
diff --git a/packages/rhythmbox/.mtn2git_empty b/packages/rhythmbox/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/rhythmbox/.mtn2git_empty
diff --git a/packages/rhythmbox/rhythmbox/.mtn2git_empty b/packages/rhythmbox/rhythmbox/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/rhythmbox/rhythmbox/.mtn2git_empty
diff --git a/packages/rhythmbox/rhythmbox/ogg.m4 b/packages/rhythmbox/rhythmbox/ogg.m4
index e69de29bb2..1f643f1204 100644
--- a/packages/rhythmbox/rhythmbox/ogg.m4
+++ b/packages/rhythmbox/rhythmbox/ogg.m4
@@ -0,0 +1,102 @@
+# Configure paths for libogg
+# Jack Moffitt <jack@icecast.org> 10-21-2000
+# Shamelessly stolen from Owen Taylor and Manish Singh
+define(arch-tag)
+# arch-tag: Autoconf macro for checking libogg
+
+dnl XIPH_PATH_OGG([ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
+dnl Test for libogg, and define OGG_CFLAGS and OGG_LIBS
+dnl
+AC_DEFUN(MM_PATH_OGG,
+[dnl
+dnl Get the cflags and libraries
+dnl
+AC_ARG_WITH(ogg,[ --with-ogg=PFX Prefix where libogg is installed (optional)], ogg_prefix="$withval", ogg_prefix="")
+AC_ARG_WITH(ogg-libraries,[ --with-ogg-libraries=DIR Directory where libogg library is installed (optional)], ogg_libraries="$withval", ogg_libraries="")
+AC_ARG_WITH(ogg-includes,[ --with-ogg-includes=DIR Directory where libogg header files are installed (optional)], ogg_includes="$withval", ogg_includes="")
+AC_ARG_ENABLE(oggtest, [ --disable-oggtest Do not try to compile and run a test Ogg program],, enable_oggtest=yes)
+
+ if test "x$ogg_libraries" != "x" ; then
+ OGG_LIBS="-L$ogg_libraries"
+ elif test "x$ogg_prefix" != "x" ; then
+ OGG_LIBS="-L$ogg_prefix/lib"
+ elif test "x$prefix" != "xNONE" ; then
+ OGG_LIBS="-L$prefix/lib"
+ fi
+
+ OGG_LIBS="$OGG_LIBS -logg"
+
+ if test "x$ogg_includes" != "x" ; then
+ OGG_CFLAGS="-I$ogg_includes"
+ elif test "x$ogg_prefix" != "x" ; then
+ OGG_CFLAGS="-I$ogg_prefix/include"
+ fi
+
+ AC_MSG_CHECKING(for Ogg)
+ no_ogg=""
+
+
+ if test "x$enable_oggtest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $OGG_CFLAGS"
+ LIBS="$LIBS $OGG_LIBS"
+dnl
+dnl Now check if the installed Ogg is sufficiently new.
+dnl
+ rm -f conf.oggtest
+ AC_TRY_RUN([
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <ogg/ogg.h>
+
+int main ()
+{
+ system("touch conf.oggtest");
+ return 0;
+}
+
+],, no_ogg=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+
+ if test "x$no_ogg" = "x" ; then
+ AC_MSG_RESULT(yes)
+ ifelse([$1], , :, [$1])
+ else
+ AC_MSG_RESULT(no)
+ if test -f conf.oggtest ; then
+ :
+ else
+ echo "*** Could not run Ogg test program, checking why..."
+ CFLAGS="$CFLAGS $OGG_CFLAGS"
+ LIBS="$LIBS $OGG_LIBS"
+ AC_TRY_LINK([
+#include <stdio.h>
+#include <ogg/ogg.h>
+], [ return 0; ],
+ [ echo "*** The test program compiled, but did not run. This usually means"
+ echo "*** that the run-time linker is not finding Ogg or finding the wrong"
+ echo "*** version of Ogg. If it is not finding Ogg, you'll need to set your"
+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
+ echo "*** to the installed location Also, make sure you have run ldconfig if that"
+ echo "*** is required on your system"
+ echo "***"
+ echo "*** If you have an old version installed, it is best to remove it, although"
+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"],
+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
+ echo "*** exact error that occured. This usually means Ogg was incorrectly installed"
+ echo "*** or that you have moved Ogg since it was installed." ])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ OGG_CFLAGS=""
+ OGG_LIBS=""
+ ifelse([$2], , :, [$2])
+ fi
+ AC_SUBST(OGG_CFLAGS)
+ AC_SUBST(OGG_LIBS)
+ rm -f conf.oggtest
+])
diff --git a/packages/rhythmbox/rhythmbox/vorbis.m4 b/packages/rhythmbox/rhythmbox/vorbis.m4
index e69de29bb2..4761b32661 100644
--- a/packages/rhythmbox/rhythmbox/vorbis.m4
+++ b/packages/rhythmbox/rhythmbox/vorbis.m4
@@ -0,0 +1,122 @@
+# Configure paths for libvorbis
+# Jack Moffitt <jack@icecast.org> 10-21-2000
+# Shamelessly stolen from Owen Taylor and Manish Singh
+# thomasvs added check for vorbis_bitrate_addblock which is new in rc3
+define(arch-tag)
+# arch-tag: Autoconf macro for checking libvorbis
+
+dnl XIPH_PATH_VORBIS([ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
+dnl Test for libvorbis, and define VORBIS_CFLAGS and VORBIS_LIBS
+dnl
+AC_DEFUN(MM_PATH_VORBIS,
+[dnl
+dnl Get the cflags and libraries
+dnl
+AC_ARG_WITH(vorbis,[ --with-vorbis=PFX Prefix where libvorbis is installed (optional)], vorbis_prefix="$withval", vorbis_prefix="")
+AC_ARG_WITH(vorbis-libraries,[ --with-vorbis-libraries=DIR Directory where libvorbis library is installed (optional)], vorbis_libraries="$withval", vorbis_libraries="")
+AC_ARG_WITH(vorbis-includes,[ --with-vorbis-includes=DIR Directory where libvorbis header files are installed (optional)], vorbis_includes="$withval", vorbis_includes="")
+AC_ARG_ENABLE(vorbistest, [ --disable-vorbistest Do not try to compile and run a test Vorbis program],, enable_vorbistest=yes)
+
+ if test "x$vorbis_libraries" != "x" ; then
+ VORBIS_LIBS="-L$vorbis_libraries"
+ elif test "x$vorbis_prefix" != "x" ; then
+ VORBIS_LIBS="-L$vorbis_prefix/lib"
+ elif test "x$prefix" != "xNONE"; then
+ VORBIS_LIBS="-L$prefix/lib"
+ fi
+
+ VORBIS_LIBS="$VORBIS_LIBS -lvorbis -lm"
+ VORBISFILE_LIBS="-lvorbisfile"
+ VORBISENC_LIBS="-lvorbisenc"
+
+ if test "x$vorbis_includes" != "x" ; then
+ VORBIS_CFLAGS="-I$vorbis_includes"
+ elif test "x$vorbis_prefix" != "x" ; then
+ VORBIS_CFLAGS="-I$vorbis_prefix/include"
+ fi
+
+
+ AC_MSG_CHECKING(for Vorbis)
+ no_vorbis=""
+
+
+ if test "x$enable_vorbistest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $VORBIS_CFLAGS $OGG_CFLAGS"
+ LIBS="$LIBS $VORBIS_LIBS $VORBISENC_LIBS $OGG_LIBS"
+dnl
+dnl Now check if the installed Vorbis is sufficiently new.
+dnl
+ rm -f conf.vorbistest
+ AC_TRY_RUN([
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <vorbis/codec.h>
+#include <vorbis/vorbisenc.h>
+
+int main ()
+{
+ vorbis_block vb;
+ vorbis_dsp_state vd;
+ vorbis_info vi;
+
+ vorbis_info_init (&vi);
+ vorbis_encode_init (&vi, 2, 44100, -1, 128000, -1);
+ vorbis_analysis_init (&vd, &vi);
+ vorbis_block_init (&vd, &vb);
+ /* this function was added in 1.0rc3, so this is what we're testing for */
+ vorbis_bitrate_addblock (&vb);
+
+ system("touch conf.vorbistest");
+ return 0;
+}
+
+],, no_vorbis=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+
+ if test "x$no_vorbis" = "x" ; then
+ AC_MSG_RESULT(yes)
+ ifelse([$1], , :, [$1])
+ else
+ AC_MSG_RESULT(no)
+ if test -f conf.vorbistest ; then
+ :
+ else
+ echo "*** Could not run Vorbis test program, checking why..."
+ CFLAGS="$CFLAGS $VORBIS_CFLAGS"
+ LIBS="$LIBS $VORBIS_LIBS $OGG_LIBS"
+ AC_TRY_LINK([
+#include <stdio.h>
+#include <vorbis/codec.h>
+], [ return 0; ],
+ [ echo "*** The test program compiled, but did not run. This usually means"
+ echo "*** that the run-time linker is not finding Vorbis or finding the wrong"
+ echo "*** version of Vorbis. If it is not finding Vorbis, you'll need to set your"
+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
+ echo "*** to the installed location Also, make sure you have run ldconfig if that"
+ echo "*** is required on your system"
+ echo "***"
+ echo "*** If you have an old version installed, it is best to remove it, although"
+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"],
+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
+ echo "*** exact error that occured. This usually means Vorbis was incorrectly installed"
+ echo "*** or that you have moved Vorbis since it was installed." ])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ VORBIS_CFLAGS=""
+ VORBIS_LIBS=""
+ VORBISFILE_LIBS=""
+ VORBISENC_LIBS=""
+ ifelse([$2], , :, [$2])
+ fi
+ AC_SUBST(VORBIS_CFLAGS)
+ AC_SUBST(VORBIS_LIBS)
+ AC_SUBST(VORBISFILE_LIBS)
+ AC_SUBST(VORBISENC_LIBS)
+ rm -f conf.vorbistest
+])
diff --git a/packages/rhythmbox/rhythmbox_0.8.5.bb b/packages/rhythmbox/rhythmbox_0.8.5.bb
index e69de29bb2..aa1ec636c0 100644
--- a/packages/rhythmbox/rhythmbox_0.8.5.bb
+++ b/packages/rhythmbox/rhythmbox_0.8.5.bb
@@ -0,0 +1,28 @@
+LICENSE = GPL
+SECTION = "unknown"
+PR = "r3"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/rhythmbox/0.8/rhythmbox-${PV}.tar.gz \
+ file://ogg.m4 file://vorbis.m4"
+
+DEPENDS = "gstreamer gst-plugins libgnomeui"
+
+EXTRA_OECONF = "--disable-schemas-install"
+
+FILES_${PN} += " ${libdir}/bonobo/servers ${libdir}/bonobo/*.so ${datadir}/omf ${datadir}/mime-info \
+ ${datadir}/application-registry ${datadir}/gnome-2.0 ${datadir}/idl"
+FILES_${PN}-doc += " ${datadir}/gnome/help"
+FILES_${PN}-dev += " ${libdir}/bonobo/*.la ${libdir}/bonobo/*.a"
+
+RDEPENDS_${PN} = "gst-plugin-gnomevfs gst-plugin-esd gst-plugin-mad gst-plugin-ivorbis"
+
+do_configure_prepend() {
+ mkdir -p ${S}/m4
+ cp ${WORKDIR}/ogg.m4 ${S}/m4/
+ cp ${WORKDIR}/vorbis.m4 ${S}/m4/
+}
+
+inherit autotools gconf
+
+do_compile() {
+ oe_runmake ORBIT_IDL=`which orbit-idl-2`
+}
diff --git a/packages/rhythmbox/rhythmbox_0.8.7.bb b/packages/rhythmbox/rhythmbox_0.8.7.bb
index e69de29bb2..ada2fa6df1 100644
--- a/packages/rhythmbox/rhythmbox_0.8.7.bb
+++ b/packages/rhythmbox/rhythmbox_0.8.7.bb
@@ -0,0 +1,28 @@
+LICENSE = GPL
+SECTION = "unknown"
+PR = "r0"
+
+inherit gnome
+
+SRC_URI += "file://ogg.m4 file://vorbis.m4"
+
+DEPENDS = "gstreamer gst-plugins libgnomeui"
+
+EXTRA_OECONF = "--disable-schemas-install"
+
+FILES_${PN} += " ${libdir}/bonobo/servers ${libdir}/bonobo/*.so ${datadir}/omf ${datadir}/mime-info \
+ ${datadir}/application-registry ${datadir}/gnome-2.0 ${datadir}/idl"
+FILES_${PN}-doc += " ${datadir}/gnome/help"
+FILES_${PN}-dev += " ${libdir}/bonobo/*.la ${libdir}/bonobo/*.a"
+
+RDEPENDS_${PN} = "gst-plugin-gnomevfs gst-plugin-esd gst-plugin-mad gst-plugin-ivorbis"
+
+do_configure_prepend() {
+ mkdir -p ${S}/m4
+ cp ${WORKDIR}/ogg.m4 ${S}/m4/
+ cp ${WORKDIR}/vorbis.m4 ${S}/m4/
+}
+
+do_compile() {
+ oe_runmake ORBIT_IDL=`which orbit-idl-2`
+}