aboutsummaryrefslogtreecommitdiffstats
path: root/packages/rpm2cpio
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/rpm2cpio
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/rpm2cpio')
-rw-r--r--packages/rpm2cpio/rpm2cpio-native_1.2_2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/rpm2cpio/rpm2cpio-native_1.2_2.bb b/packages/rpm2cpio/rpm2cpio-native_1.2_2.bb
index e69de29bb2..7a460decda 100644
--- a/packages/rpm2cpio/rpm2cpio-native_1.2_2.bb
+++ b/packages/rpm2cpio/rpm2cpio-native_1.2_2.bb
@@ -0,0 +1,21 @@
+# rpm2cpio-native build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DEPENDS="perl-native"
+LICENSE="BSD"
+SRC_URI="http://ftp.rutgers.edu/pub/FreeBSD/ports/packages/archivers/rpm2cpio-1.2_2.tgz"
+
+inherit native
+
+S="${WORKDIR}"
+
+do_compile() {
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ sed -e '1,1s|${bindir}/|${bindir}/env |' bin/rpm2cpio.pl \
+ > ${STAGING_BINDIR}/rpm2cpio.pl
+ chmod 0755 ${STAGING_BINDIR}/rpm2cpio.pl
+}