aboutsummaryrefslogtreecommitdiffstats
path: root/packages/rrdtool/rrdtool_1.0.49.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/rrdtool/rrdtool_1.0.49.bb
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/rrdtool/rrdtool_1.0.49.bb')
-rw-r--r--packages/rrdtool/rrdtool_1.0.49.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/rrdtool/rrdtool_1.0.49.bb b/packages/rrdtool/rrdtool_1.0.49.bb
index e69de29bb2..1a148c81ae 100644
--- a/packages/rrdtool/rrdtool_1.0.49.bb
+++ b/packages/rrdtool/rrdtool_1.0.49.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "RRD is the Acronym for Round Robin Database. RRD is a system to store and display time-series data (i.e. network bandwidth, machine-room temperature, server load average)."
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+HOMEPAGE = "http://people.ee.ethz.ch/~oetiker/webtools/rrdtool"
+LICENSE = "GPLv2"
+DEPENDS = "libpng zlib"
+SRC_URI = "http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/rrdtool-${PV}.tar.gz \
+ file://perl-make-options.diff;patch=1;pnum=0"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-shared --enable-local-libpng --enable-local-zlib --program-prefix=''"
+
+do_install_append() {
+ install -d ${D}/${docdir}/rrdtool/
+ mv ${D}/usr/html ${D}/${docdir}/rrdtool/
+ mv ${D}/usr/doc/* ${D}/${docdir}/rrdtool/
+ mv ${D}/usr/examples ${D}/${docdir}/rrdtool/
+ mv ${D}/usr/contrib ${D}/${docdir}/rrdtool/
+}
+
+FILES_${PN} += "${libdir}/perl"
+
+DEPENDS_rddtool-perl = "perl-module-lib perl-module-dynaloader" \ No newline at end of file