aboutsummaryrefslogtreecommitdiffstats
path: root/packages/rxvt-unicode
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-01 18:40:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-01 18:40:55 +0000
commit78515aa5900086d8ff38ba46c421f06504e533f4 (patch)
tree9adfbf97eb5e29f802d328dc2d96f372962ae3b4 /packages/rxvt-unicode
parentc2b17008ce562db7e7e794611dbdd10764599967 (diff)
downloadopenembedded-78515aa5900086d8ff38ba46c421f06504e533f4.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/01 18:36:32+00:00 nexus.co.uk!pb Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into stealth.nexus.co.uk:/home/pb/oe/oe 2005/01/01 18:35:06+00:00 nexus.co.uk!pb Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into stealth.nexus.co.uk:/home/pb/oe/oe 2005/01/01 19:34:59+01:00 hrw.one.pl!hrw add missing patch to gtk+ 2.6.0 2005/01/01 19:24:58+01:00 hrw.one.pl!hrw added missing dependencies to librsvg 2005/01/01 19:23:00+01:00 hrw.one.pl!hrw Merge bk://oe-devel@oe-devel.bkbits.net/openembedded/ into home.hrw.one.pl:/home/hrw/zaurus/bb/openembedded 2005/01/01 19:17:46+01:00 handhelds.org!CoreDump Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into handhelds.org:/home/mhentges/OpenEmbedded/bitbake/openembedded 2005/01/01 10:40:49-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2005/01/01 10:40:21-08:00 (none)!ggilbert Many files: Adding more LICENSES 2005/01/01 18:34:46+00:00 nexus.co.uk!pb add gpe-lights to gpe-task-games 2005/01/01 19:17:34+01:00 handhelds.org!CoreDump prboom_2.3.1.bb: prboom: Set DEFAULT_PREFERRENCE = -1 for 2.3.1 prboom_2.2.6.bb, prboom.png, prboom.desktop, m4.patch: new file 2005/01/01 17:39:51+00:00 nexus.co.uk!pb Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into stealth.nexus.co.uk:/home/pb/oe/oe 2005/01/01 17:39:24+00:00 nexus.co.uk!pb disable JIS encodings in rxvt-unicode 2005/01/01 17:17:42+01:00 hrw.one.pl!hrw Merge bk://oe-devel@oe-devel.bkbits.net/openembedded/ into home.hrw.one.pl:/home/hrw/zaurus/bb/openembedded 2005/01/01 16:50:14+01:00 hrw.one.pl!hrw Merge bk://oe-devel@oe-devel.bkbits.net/openembedded/ into home.hrw.one.pl:/home/hrw/zaurus/bb/openembedded 2004/12/31 23:30:31+01:00 hrw.one.pl!hrw removed verdana & georgia fonts from meta-opie due to LICENSE BKrev: 41d6eeb7-0v1WWxOR9ezdVHMi6M7xA
Diffstat (limited to 'packages/rxvt-unicode')
-rw-r--r--packages/rxvt-unicode/rxvt-unicode_4.7.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/packages/rxvt-unicode/rxvt-unicode_4.7.bb b/packages/rxvt-unicode/rxvt-unicode_4.7.bb
index e69de29bb2..335448ccf3 100644
--- a/packages/rxvt-unicode/rxvt-unicode_4.7.bb
+++ b/packages/rxvt-unicode/rxvt-unicode_4.7.bb
@@ -0,0 +1,55 @@
+SECTION = "x11/utils"
+DEPENDS = "x11 xt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+PR = "r2"
+LICENSE = "GPL"
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}