aboutsummaryrefslogtreecommitdiffstats
path: root/packages/rxvt-unicode
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-03-01 18:55:42 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-03-01 18:55:42 +0000
commit83e29729e7e1c346bb91915b76d03c18c00a1d4b (patch)
tree4cd8cffbc20b4eddf35cde630aca32eb7b624393 /packages/rxvt-unicode
parentbae07f485b55b4038b65e117016ea6ff7498eca9 (diff)
downloadopenembedded-83e29729e7e1c346bb91915b76d03c18c00a1d4b.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/28 13:18:40+00:00 nexus.co.uk!pb bump PR on task-bootstrap 2005/02/28 13:15:39+00:00 nexus.co.uk!pb fix up rxvt-unicode 2005/02/28 13:09:35+00:00 nexus.co.uk!pb add missing dependency on libgcrypt 2005/02/28 12:43:15+00:00 nexus.co.uk!pb update glib-2.0 to 2.6.3 BKrev: 4224baaeEmF4SHogRukZlbI5BN6q9A
Diffstat (limited to 'packages/rxvt-unicode')
-rw-r--r--packages/rxvt-unicode/rxvt-unicode_5.2.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/packages/rxvt-unicode/rxvt-unicode_5.2.bb b/packages/rxvt-unicode/rxvt-unicode_5.2.bb
index e69de29bb2..fc39d1109d 100644
--- a/packages/rxvt-unicode/rxvt-unicode_5.2.bb
+++ b/packages/rxvt-unicode/rxvt-unicode_5.2.bb
@@ -0,0 +1,53 @@
+SECTION = "x11/utils"
+DEPENDS = "x11 xt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-${PV}.tar.bz2 \
+ file://signedchar.patch;patch=1"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}