aboutsummaryrefslogtreecommitdiffstats
path: root/packages/rxvt-unicode
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-09-19 13:57:02 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-19 13:57:02 +0000
commita9f11d651cde87ee45d0a271a5409e3fffb5c27c (patch)
tree38f058cd449a71fa20dcc9adc3d28e3b453d70e1 /packages/rxvt-unicode
parent7914d8ff10241a3d5fdf719fc7b82f7eee643666 (diff)
downloadopenembedded-a9f11d651cde87ee45d0a271a5409e3fffb5c27c.tar.gz
packages/rxvt-unicode/ : add 5.6 + patch
Diffstat (limited to 'packages/rxvt-unicode')
-rw-r--r--packages/rxvt-unicode/rxvt-unicode-5.6/.mtn2git_empty0
-rw-r--r--packages/rxvt-unicode/rxvt-unicode-5.6/xwc.patch24
-rw-r--r--packages/rxvt-unicode/rxvt-unicode_5.6.bb55
3 files changed, 79 insertions, 0 deletions
diff --git a/packages/rxvt-unicode/rxvt-unicode-5.6/.mtn2git_empty b/packages/rxvt-unicode/rxvt-unicode-5.6/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/rxvt-unicode/rxvt-unicode-5.6/.mtn2git_empty
diff --git a/packages/rxvt-unicode/rxvt-unicode-5.6/xwc.patch b/packages/rxvt-unicode/rxvt-unicode-5.6/xwc.patch
new file mode 100644
index 0000000000..eb87b84b25
--- /dev/null
+++ b/packages/rxvt-unicode/rxvt-unicode-5.6/xwc.patch
@@ -0,0 +1,24 @@
+diff -urNd ../rxvt-unicode-5.3-r2/rxvt-unicode-5.3/src/screen.C rxvt-unicode-5.3/src/screen.C
+--- ../rxvt-unicode-5.3-r2/rxvt-unicode-5.3/src/screen.C 2005-02-22 21:39:10 +00:00
++++ rxvt-unicode-5.3/src/screen.C 2005-04-05 22:12:45 +01:00
+@@ -3064,7 +3064,7 @@
+ else
+ rxvt_warn ("can't get primary selection, ignoring.\n");
+
+-#if 0
++#ifdef HAVE_XWC
+ XTextProperty ct;
+
+ if (XwcTextListToTextProperty (display->display, &selection.text, 1, XStringStyle, &ct) >= 0)
+@@ -3648,9 +3648,11 @@
+ }
+ else
+ #endif
++#ifdef HAVE_XWC
+ if (XwcTextListToTextProperty (disp, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
+ freect = 1;
+ else
++#endif
+ {
+ /* if we failed to convert then send it raw */
+ ct.value = (unsigned char *)cl;
diff --git a/packages/rxvt-unicode/rxvt-unicode_5.6.bb b/packages/rxvt-unicode/rxvt-unicode_5.6.bb
new file mode 100644
index 0000000000..92915bf872
--- /dev/null
+++ b/packages/rxvt-unicode/rxvt-unicode_5.6.bb
@@ -0,0 +1,55 @@
+SECTION = "x11/utils"
+DEPENDS = "x11 xt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+PR = "r2"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-rxvt-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}