aboutsummaryrefslogtreecommitdiffstats
path: root/packages/rxvt-unicode
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-02-09 10:08:17 +0000
committerChris Lord <chris@openedhand.com>2005-02-09 10:08:17 +0000
commitead81927963fb9513ffb18bc50d7f4ced7198117 (patch)
tree651e7c6c877f6735f9b70d86ae4944490834e517 /packages/rxvt-unicode
parentf387b25a48920b7e4cf41ff6d35d69c75e0cbf74 (diff)
downloadopenembedded-ead81927963fb9513ffb18bc50d7f4ced7198117.tar.gz
Fix src uri for rxvt-unicode 4.8 and add rxvt-unicode 4.9.
BKrev: 4209e1116WU7eQv726rclOdYKGcE7g
Diffstat (limited to 'packages/rxvt-unicode')
-rw-r--r--packages/rxvt-unicode/rxvt-unicode_4.8.bb55
-rw-r--r--packages/rxvt-unicode/rxvt-unicode_4.9.bb0
2 files changed, 55 insertions, 0 deletions
diff --git a/packages/rxvt-unicode/rxvt-unicode_4.8.bb b/packages/rxvt-unicode/rxvt-unicode_4.8.bb
index e69de29bb2..94bd63e9d3 100644
--- a/packages/rxvt-unicode/rxvt-unicode_4.8.bb
+++ b/packages/rxvt-unicode/rxvt-unicode_4.8.bb
@@ -0,0 +1,55 @@
+SECTION = "x11/utils"
+DEPENDS = "x11 xt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+PR = "r2"
+LICENSE = "GPL"
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-plain-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}
diff --git a/packages/rxvt-unicode/rxvt-unicode_4.9.bb b/packages/rxvt-unicode/rxvt-unicode_4.9.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/rxvt-unicode/rxvt-unicode_4.9.bb