aboutsummaryrefslogtreecommitdiffstats
path: root/packages/rxvt-unicode
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-10-18 09:10:32 +0000
committerKoen Kooi <koen@openembedded.org>2006-10-18 09:10:32 +0000
commitf1dd4f3e9fe5216a38130bf30bea132710669ace (patch)
tree3dd2dd46b4189fe9d57d6709dba694135018f899 /packages/rxvt-unicode
parentf680f934863dd0f4f673cf2f54efd61ccb40c270 (diff)
downloadopenembedded-f1dd4f3e9fe5216a38130bf30bea132710669ace.tar.gz
rxvt-unicode: add 7.9
Diffstat (limited to 'packages/rxvt-unicode')
-rw-r--r--packages/rxvt-unicode/rxvt-unicode-7.9/.mtn2git_empty0
-rw-r--r--packages/rxvt-unicode/rxvt-unicode-7.9/xwc.patch23
-rw-r--r--packages/rxvt-unicode/rxvt-unicode_7.9.bb54
3 files changed, 77 insertions, 0 deletions
diff --git a/packages/rxvt-unicode/rxvt-unicode-7.9/.mtn2git_empty b/packages/rxvt-unicode/rxvt-unicode-7.9/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/rxvt-unicode/rxvt-unicode-7.9/.mtn2git_empty
diff --git a/packages/rxvt-unicode/rxvt-unicode-7.9/xwc.patch b/packages/rxvt-unicode/rxvt-unicode-7.9/xwc.patch
new file mode 100644
index 0000000000..fbab74aa3d
--- /dev/null
+++ b/packages/rxvt-unicode/rxvt-unicode-7.9/xwc.patch
@@ -0,0 +1,23 @@
+--- rxvt-unicode-7.7/src/screen.C.orig 2006-05-11 14:48:12.000000000 +0100
++++ rxvt-unicode-7.7/src/screen.C 2006-05-11 14:49:37.000000000 +0100
+@@ -3061,7 +3061,7 @@
+ return false;
+ }
+
+-#if 0
++#if HAVE_XWC
+ XTextProperty ct;
+
+ if (XwcTextListToTextProperty (dpy, &selection.text, 1, XStringStyle, &ct) >= 0)
+@@ -3628,9 +3628,11 @@
+ }
+ else
+ #endif
++#if HAVE_XWC
+ if (XwcTextListToTextProperty (dpy, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
+ freect = 1;
+ else
++#endif
+ {
+ /* if we failed to convert then send it raw */
+ ct.value = (unsigned char *)cl;
diff --git a/packages/rxvt-unicode/rxvt-unicode_7.9.bb b/packages/rxvt-unicode/rxvt-unicode_7.9.bb
new file mode 100644
index 0000000000..532fe2da63
--- /dev/null
+++ b/packages/rxvt-unicode/rxvt-unicode_7.9.bb
@@ -0,0 +1,54 @@
+SECTION = "x11/utils"
+DEPENDS = "virtual/libx11 libxt libxft libxpm"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+PACKAGES =+ "${PN}-daemon ${PN}-control"
+FILES_${PN}-daemon = "${bindir}/rxvtd"
+FILES_${PN}-control = "${bindir}/rxvtc"
+
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-rxvt-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.. \
+ --enable-xpm-background \
+ --disable-perl \
+ --with-xpm-includes=${STAGING_INCDIR} \
+ --with-xpm-libs=${STAGING_LIBDIR}"
+
+do_configure_prepend () {
+ cp aclocal.m4 acinclude.m4
+}
+
+do_compile_prepend () {
+ echo '#define UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+