aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sane-backends
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-07-06 00:03:06 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-06 00:03:06 +0000
commit7e09f9e48816d814b0838b2967eaf51889eff28c (patch)
tree988194bbc518e6b6e8bb283f984248594af1b734 /packages/sane-backends
parent3a0470ba3c87a90356703fe13bee7c2430aa561b (diff)
downloadopenembedded-7e09f9e48816d814b0838b2967eaf51889eff28c.tar.gz
Added package sane-backends.
Diffstat (limited to 'packages/sane-backends')
-rw-r--r--packages/sane-backends/.mtn2git_empty0
-rw-r--r--packages/sane-backends/sane-backends-1.0.15/.mtn2git_empty0
-rw-r--r--packages/sane-backends/sane-backends-1.0.15/Makefile.in.patch11
-rw-r--r--packages/sane-backends/sane-backends-1.0.15/sane-plustek.patch52
-rw-r--r--packages/sane-backends/sane-backends_1.0.15.bb14
5 files changed, 77 insertions, 0 deletions
diff --git a/packages/sane-backends/.mtn2git_empty b/packages/sane-backends/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/sane-backends/.mtn2git_empty
diff --git a/packages/sane-backends/sane-backends-1.0.15/.mtn2git_empty b/packages/sane-backends/sane-backends-1.0.15/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/sane-backends/sane-backends-1.0.15/.mtn2git_empty
diff --git a/packages/sane-backends/sane-backends-1.0.15/Makefile.in.patch b/packages/sane-backends/sane-backends-1.0.15/Makefile.in.patch
new file mode 100644
index 0000000000..d73a2f0fb5
--- /dev/null
+++ b/packages/sane-backends/sane-backends-1.0.15/Makefile.in.patch
@@ -0,0 +1,11 @@
+--- sane-backends/Makefile.in 2004-05-04 11:44:26.000000000 -0400
++++ sane-backends-1.0.15/Makefile.in 2005-05-11 12:43:20.870000000 -0400
+@@ -33,7 +33,7 @@
+
+ @SET_MAKE@
+
+-SUBDIRS = include lib sanei backend frontend tools doc po
++SUBDIRS = include lib sanei backend frontend tools po
+
+ DISTFILES = AUTHORS COPYING ChangeLog ChangeLog-1.0.0 ChangeLog-1.0.1 \
+ ChangeLog-1.0.2 ChangeLog-1.0.3 ChangeLog-1.0.4 ChangeLog-1.0.5 \
diff --git a/packages/sane-backends/sane-backends-1.0.15/sane-plustek.patch b/packages/sane-backends/sane-backends-1.0.15/sane-plustek.patch
new file mode 100644
index 0000000000..f6920c6e22
--- /dev/null
+++ b/packages/sane-backends/sane-backends-1.0.15/sane-plustek.patch
@@ -0,0 +1,52 @@
+--- sane-backends-1.0.15/backend/plustek-usb.h.orig 2005-07-06 00:45:43.000000000 +0200
++++ sane-backends-1.0.15/backend/plustek-usb.h 2005-07-06 00:47:36.000000000 +0200
+@@ -106,17 +106,20 @@
+ #define _PHILO2WORD(x) ((u_short)x->bHi * 256U + x->bLo)
+
+ /* useful for RGB-values */
++#define PACKED8 __attribute__ ((packed,aligned(1)))
++#define PACKED16 __attribute__ ((packed,aligned(2)))
++
+ typedef struct {
+ u_char Red;
+ u_char Green;
+ u_char Blue;
+-} RGBByteDef, *pRGBByteDef;
++} PACKED8 RGBByteDef, *pRGBByteDef;
+
+ typedef struct {
+ u_short Red;
+ u_short Green;
+ u_short Blue;
+-} RGBUShortDef, *pRGBUShortDef;
++} PACKED16 RGBUShortDef, *pRGBUShortDef;
+
+ typedef struct {
+ u_long Red;
+@@ -126,22 +129,22 @@
+
+ typedef struct {
+ u_char a_bColor[3];
+-} ColorByteDef, *pColorByteDef;
++} PACKED8 ColorByteDef, *pColorByteDef;
+
+ typedef struct {
+ u_char bHi;
+ u_char bLo;
+-} HiLoDef, *pHiLoDef;
++} PACKED8 HiLoDef, *pHiLoDef;
+
+ typedef union {
+ HiLoDef HiLo[3];
+ u_short Colors[3];
+-} ColorWordDef, *pColorWordDef;
++} PACKED16 ColorWordDef, *pColorWordDef;
+
+ typedef union {
+ HiLoDef HiLo;
+ u_short Mono;
+-} MonoWordDef, *pMonoWordDef;
++} PACKED16 MonoWordDef, *pMonoWordDef;
+
+ typedef union {
+
diff --git a/packages/sane-backends/sane-backends_1.0.15.bb b/packages/sane-backends/sane-backends_1.0.15.bb
new file mode 100644
index 0000000000..6897aef141
--- /dev/null
+++ b/packages/sane-backends/sane-backends_1.0.15.bb
@@ -0,0 +1,14 @@
+MAINTAINER="Oyvind Repvik <nail@nslu2-linux.org>"
+DESCRIPTION="Scanner drivers for SANE"
+PR="r0"
+DEPENDS="jpeg libusb"
+
+SRC_URI="ftp://ftp.sane-project.org/pub/sane/sane-backends-${PV}/sane-backends-${PV}.tar.gz \
+ file://sane-plustek.patch;patch=1\
+ file://Makefile.in.patch;patch=1"
+
+EXTRA_OECONF="--prefix=/usr --sysconfdir=/etc --disable-translations"
+
+inherit autotools
+
+