aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sapwood
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-03-29 14:16:00 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-03-29 14:16:00 +0000
commit0b25d92b900c10d66740b5cd37d000d2fcafc356 (patch)
tree8be7518ab58b0e50c4502cc3de19bf62c37f67da /packages/sapwood
parentff83f7e66a26a77d79a27a2ee0c693cff35be9d5 (diff)
downloadopenembedded-0b25d92b900c10d66740b5cd37d000d2fcafc356.tar.gz
sapwood: fixed packaging, recreated patch
Diffstat (limited to 'packages/sapwood')
-rw-r--r--packages/sapwood/sapwood/sockets.patch75
-rw-r--r--packages/sapwood/sapwood_svn.bb7
2 files changed, 18 insertions, 64 deletions
diff --git a/packages/sapwood/sapwood/sockets.patch b/packages/sapwood/sapwood/sockets.patch
index 1568206e2a..4e3a8e2d41 100644
--- a/packages/sapwood/sapwood/sockets.patch
+++ b/packages/sapwood/sapwood/sockets.patch
@@ -1,9 +1,12 @@
---- configure.in.old 2005-06-10 17:04:52.000000000 +0200
-+++ configure.in 2005-06-10 17:20:47.000000000 +0200
-@@ -13,61 +13,61 @@
+Index: sapwood/configure.in
+===================================================================
+--- sapwood.orig/configure.in 2007-03-29 16:04:12.000000000 +0200
++++ sapwood/configure.in 2007-03-29 16:04:15.000000000 +0200
+@@ -13,63 +13,6 @@
+ AC_PROG_INSTALL
AC_PROG_MAKE_SET
- dnl abstract sockets namespace checks, from dbus
+-dnl abstract sockets namespace checks, from dbus
-AC_ARG_ENABLE(abstract-sockets,
- [AC_HELP_STRING([--enable-abstract-sockets],
- [use abstract socket namespace (linux only)])],
@@ -13,21 +16,12 @@
-AC_MSG_CHECKING(abstract socket namespace)
-AC_RUN_IFELSE([AC_LANG_PROGRAM(
-[[
-+#AC_ARG_ENABLE(abstract-sockets,
-+# [AC_HELP_STRING([--enable-abstract-sockets],
-+# [use abstract socket namespace (linux only)])],
-+# [enable_abstract_sockets=$enableval],
-+# [enable_abstract_sockets=no])
-+#
-+#AC_MSG_CHECKING(abstract socket namespace)
-+#AC_RUN_IFELSE([AC_LANG_PROGRAM(
-+#[[
- #include <sys/types.h>
- #include <stdlib.h>
- #include <stdio.h>
- #include <sys/socket.h>
- #include <sys/un.h>
- #include <errno.h>
+-#include <sys/types.h>
+-#include <stdlib.h>
+-#include <stdio.h>
+-#include <sys/socket.h>
+-#include <sys/un.h>
+-#include <errno.h>
-]],
-[[
- int listen_fd;
@@ -68,46 +62,7 @@
-if test x$enable_abstract_sockets = xno; then
- have_abstract_sockets=no
-fi
-+#]],
-+#[[
-+# int listen_fd;
-+# struct sockaddr_un addr;
-+#
-+# listen_fd = socket (PF_UNIX, SOCK_STREAM, 0);
-+
-+# if (listen_fd < 0)
-+# {
-+# fprintf (stderr, "socket() failed: %s\n", strerror (errno));
-+# exit (1);
-+# }
-+#
-+# memset (&addr, '\0', sizeof (addr));
-+# addr.sun_family = AF_UNIX;
-+# strcpy (addr.sun_path, "X/tmp/sapwood-fake-socket-path-used-in-configure-test");
-+# addr.sun_path[0] = '\0'; /* this is what makes it abstract */
-+#
-+# if (bind (listen_fd, (struct sockaddr*) &addr, SUN_LEN (&addr)) < 0)
-+# {
-+# fprintf (stderr, "Abstract socket namespace bind() failed: %s\n",
-+# strerror (errno));
-+# exit (1);
-+# }
-+# else
-+# exit (0);
-+#]])],
-+# [have_abstract_sockets=no],
-+# [have_abstract_sockets=no])
-+#AC_MSG_RESULT($have_abstract_sockets)
-+
-+#if test x$enable_abstract_sockets = xyes; then
-+# if test x$have_abstract_sockets = xno; then
-+# AC_MSG_ERROR([Abstract sockets explicitly required, and support not detected.])
-+# fi
-+#fi
-+
-+#if test x$enable_abstract_sockets = xno; then
-+have_abstract_sockets=no
-+#fi
-
+-
if test x$have_abstract_sockets = xyes; then
AC_DEFINE(HAVE_ABSTRACT_SOCKETS,1,[Have abstract socket namespace])
+ fi
diff --git a/packages/sapwood/sapwood_svn.bb b/packages/sapwood/sapwood_svn.bb
index 9651ff3916..39ccacb6f6 100644
--- a/packages/sapwood/sapwood_svn.bb
+++ b/packages/sapwood/sapwood_svn.bb
@@ -1,9 +1,8 @@
DESCRIPTION = "GTK theme engine Sapwood"
LICENSE = "LGPL"
-
DEPENDS = "gtk+"
-
PV = "2.43+svn${SRCDATE}"
+PR = "r1"
SRC_URI = "svn://stage.maemo.org/svn/maemo/projects/haf/trunk/;module=sapwood;proto=https \
file://sockets.patch;patch=1 \
@@ -20,5 +19,5 @@ do_install_append () {
install -m755 ${S}/debian/sapwood-server.sh ${D}${sysconfdir}/osso-af-init/sapwood-server.sh
}
-FILES_${PN} += "${libdir}/gtk-2.0/2.10.0/engines/"
-
+FILES_${PN} += "${libdir}/gtk-2.0/*/engines/libsapwood.so"
+FILES_${PN}-dbg += "${libdir}/gtk-2.0/*/engines/.debug/libsapwood.so"