aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sdcc/files
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-10-19 21:33:36 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-10-19 21:33:36 +0000
commit005277d0efac2a2fbac100097e70c25702dc640b (patch)
treec11552031a7e1154723fdd944dcd1ceb416b35f9 /packages/sdcc/files
parentb5a18ffe5f72403f20603eba24bec52f9c7c5e33 (diff)
downloadopenembedded-005277d0efac2a2fbac100097e70c25702dc640b.tar.gz
sdcc: add native-tools patch to make it build
Diffstat (limited to 'packages/sdcc/files')
-rw-r--r--packages/sdcc/files/use-native-tools.patch80
1 files changed, 80 insertions, 0 deletions
diff --git a/packages/sdcc/files/use-native-tools.patch b/packages/sdcc/files/use-native-tools.patch
new file mode 100644
index 0000000000..d3b02c4a44
--- /dev/null
+++ b/packages/sdcc/files/use-native-tools.patch
@@ -0,0 +1,80 @@
+Index: sdcc/device/lib/Makefile.in
+===================================================================
+--- sdcc.orig/device/lib/Makefile.in
++++ sdcc/device/lib/Makefile.in
+@@ -18,8 +18,8 @@ ifndef PORTINCDIR
+ PORTINCDIR = $(INCDIR)/mcs51
+ endif
+
+-CC = $(PRJDIR)/bin/sdcc
+-CPP = $(PRJDIR)/bin/sdcpp
++CC = sdcc
++CPP = sdcpp
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+Index: sdcc/device/lib/mcs51/Makefile
+===================================================================
+--- sdcc.orig/device/lib/mcs51/Makefile
++++ sdcc/device/lib/mcs51/Makefile
+@@ -1,8 +1,8 @@
+
+ TOPDIR = ../../..
+
+-SAS = $(TOPDIR)/bin/asx8051
+-SCC = $(TOPDIR)/bin/sdcc
++SAS = asx8051
++SCC = sdcc
+
+ OBJ = crtstart.rel crtxinit.rel crtxclear.rel crtclear.rel crtxstack.rel \
+ crtpagesfr.rel
+Index: sdcc/device/lib/ds390/Makefile
+===================================================================
+--- sdcc.orig/device/lib/ds390/Makefile
++++ sdcc/device/lib/ds390/Makefile
+@@ -1,4 +1,4 @@
+-CC = ../../../bin/sdcc
++CC = sdcc
+
+ #VERBOSE = --verbose
+
+Index: sdcc/device/lib/ds400/Makefile
+===================================================================
+--- sdcc.orig/device/lib/ds400/Makefile
++++ sdcc/device/lib/ds400/Makefile
+@@ -1,4 +1,4 @@
+-CC = ../../../bin/sdcc
++CC = sdcc
+
+ #VERBOSE = --verbose
+
+Index: sdcc/device/lib/z80/Makefile
+===================================================================
+--- sdcc.orig/device/lib/z80/Makefile
++++ sdcc/device/lib/z80/Makefile
+@@ -2,8 +2,8 @@
+
+ TOPDIR = ../../..
+
+-SCC = $(TOPDIR)/bin/sdcc -mz80
+-SAS = $(TOPDIR)/bin/as-z80
++SCC = sdcc -mz80
++SAS = as-z80
+
+ OBJ = div.o mul.o putchar.o shift.o stubs.o crt0_rle.o heap.o fstubs.o
+
+Index: sdcc/device/lib/gbz80/Makefile
+===================================================================
+--- sdcc.orig/device/lib/gbz80/Makefile
++++ sdcc/device/lib/gbz80/Makefile
+@@ -2,8 +2,8 @@
+
+ TOPDIR = ../../..
+
+-SCC = $(TOPDIR)/bin/sdcc -mgbz80
+-SAS = $(TOPDIR)/bin/as-gbz80
++SCC = sdcc -mgbz80
++SAS = as-gbz80
+
+ OBJ = div.o mul.o putchar.o printf.o shift.o stubs.o crt0_rle.o heap.o fstubs.o
+