aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sdlperl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-05-30 09:00:31 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-05-30 09:00:31 +0000
commitf9ef49020cb889e0abba839eb8fab9bed657dca8 (patch)
tree3619f8ee1e868ac554f582101a90eb51b90b171f /packages/sdlperl
parent1e8d1070cb56fbddd5fdae1ff5b94de635b6da23 (diff)
downloadopenembedded-f9ef49020cb889e0abba839eb8fab9bed657dca8.tar.gz
sdl-perl 1.20.3: Fix the build of sdl-perl
* Use the cpan class to do all the work instead of manually trying to do what cpan.bbclass does. * Add some sed to stop it searching the system paths for SDL headers and to work around it expecting smpeg.h to be in an smpeg subdirectory. * Update the homepage URL. NOTE: The source for this version is no longer available, but it is the version shipped by most distro's. I just grabbed the source from an "apt-get source sdl-perl". Fixes #413.
Diffstat (limited to 'packages/sdlperl')
-rw-r--r--packages/sdlperl/sdl-perl_1.20.3.bb40
1 files changed, 9 insertions, 31 deletions
diff --git a/packages/sdlperl/sdl-perl_1.20.3.bb b/packages/sdlperl/sdl-perl_1.20.3.bb
index 80bd899dfc..6820fa05ce 100644
--- a/packages/sdlperl/sdl-perl_1.20.3.bb
+++ b/packages/sdlperl/sdl-perl_1.20.3.bb
@@ -1,40 +1,18 @@
DESCRIPTION = "Perl bindings for SDL"
-HOMEPAGE = "http://bloodgate.com/perl"
SECTION = "libs"
+HOMEPAGE = "http://sdl.perl.org/"
LICENSE = "GPL"
DEPENDS = "perl virtual/libsdl libsdl-image libsdl-gfx libsdl-ttf libsdl-mixer libsdl-net smpeg"
+PR = "r1"
-SRC_URI = "http://bloodgate.com/perl/sdl/pub/SDL_perl-${PV}.tar.gz \
- file://Makefile.patch;patch=1;pnum=0"
+SRC_URI = "http://bloodgate.com/perl/sdl/pub/SDL_perl-${PV}.tar.gz"
S = "${WORKDIR}/SDL_perl-${PV}"
-do_configure () {
- if [ -x ${S}/configure ] ; then
- cfgcmd="${S}/configure \
- -GL -GLU"
- oenote "Running $cfgcmd..."
- $cfgcmd || oefatal "oe_runconf failed"
- if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
- . ${STAGING_DIR}/${TARGET_SYS}/perl/config.sh
- sed -e "s:\(SITELIBEXP = \).*:\1${sitelibexp}:; s:\(SITEARCHEXP = \).*:\1${sitearchexp}:; s:\(INSTALLVENDORLIB = \).*:\1${D}${libdir}/perl5:; s:\(INSTALLVENDORARCH = \).*:\1${D}${libdir}/perl5:" < Makefile > Makefile.new
- mv Makefile.new Makefile
- fi
- else
- oefatal "no configure script found"
- fi
-}
-
-do_stage () {
- install -d ${STAGING_LIBDIR}/perl5/vendor_perl
- install -m 0644 ${S}/lib/SDL.pm ${STAGING_LIBDIR}/perl5/vendor_perl
-}
+inherit cpan
-do_compile () {
- oe_runmake PASTHRU_INC="${CFLAGS}"
+do_configure_prepend() {
+ # Search staging area for includes
+ sed -i -e 's:/usr/\(local/\)\{0,1\}include:${STAGING_INCDIR}:g' Makefile.linux
+ # smpeg.h isn't in a subdirectry
+ sed -i -e 's:#include <smpeg/smpeg.h>:#include <smpeg.h>:g' SDL_perl.xs
}
-
-do_install () {
- oe_runmake install_vendor
-}
-
-FILES_${PN} += '${libdir}/perl5'