aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sharp-binary-only
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/sharp-binary-only
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/sharp-binary-only')
-rw-r--r--packages/sharp-binary-only/sharp-aticore-oss_1.0.1.bb35
-rw-r--r--packages/sharp-binary-only/sharp-aticore.bb39
-rw-r--r--packages/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb12
-rw-r--r--packages/sharp-binary-only/sharp-sdmmc-support_2.4.18-rmk7-pxa3-embedix.bb10
4 files changed, 85 insertions, 11 deletions
diff --git a/packages/sharp-binary-only/sharp-aticore-oss_1.0.1.bb b/packages/sharp-binary-only/sharp-aticore-oss_1.0.1.bb
index e69de29bb2..56a9d1417b 100644
--- a/packages/sharp-binary-only/sharp-aticore-oss_1.0.1.bb
+++ b/packages/sharp-binary-only/sharp-aticore-oss_1.0.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Driver for the Ati W100 found on the Sharp Zaurus C[87]x0"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "CLOSED"
+PR = "r0"
+
+SRC_URI = "http://mirror1.pdaxrom.org/source/src/AtiCore-1.0.1.tar.bz2"
+S = "${WORKDIR}/AtiCore-1.0.1"
+
+#FILES_${PN}="${libdir}/*.so* ${bindir}/*"
+
+EXTRA_OEMAKE="CC='${CC}' AS='${AS}' AR='${AR}' LD='${LD}'"
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 testcore ${D}/${bindir}/testcore
+ install -m 0755 atitest ${D}/${bindir}/atitest
+
+ install -d ${D}/${libdir}
+ install -m 0755 libaticore.so ${D}/${libdir}/libaticore.so
+
+ install -d ${D}/${includedir}
+ install -m 0644 aticore.h ${D}/${includedir}/aticore.h
+
+ cd ${D}/${libdir}/
+ ln -s libaticore.so libaticore.so.1
+ ln -s libaticore.so libaticore.so.1.0
+ ln -s libaticore.so libaticore.so.1.0.1
+}
+
+do_stage() {
+ install -m 0644 aticore.h ${STAGING_INCDIR}
+ oe_libinstall -so libaticore ${STAGING_LIBDIR}
+}
+
diff --git a/packages/sharp-binary-only/sharp-aticore.bb b/packages/sharp-binary-only/sharp-aticore.bb
index e69de29bb2..e89418cc63 100644
--- a/packages/sharp-binary-only/sharp-aticore.bb
+++ b/packages/sharp-binary-only/sharp-aticore.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Driver for the Ati W100 found on the Sharp Zaurus C[87]x0"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "CLOSED"
+PR = "r0"
+
+SRC_URI = "http://www.mithis.com/zaurus/AtiCore.${TARGET_FPU}.tar.bz2"
+S = "${WORKDIR}/AtiCore"
+
+FILES_${PN}="${libdir}/*.so* ${bindir}/*"
+
+# And include it in the dev package
+FILES_${PN}-dev += " ${includedir}"
+
+do_make() {
+ make
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 testcore ${D}/${bindir}/testcore
+ install -m 0755 atitest ${D}/${bindir}/atitest
+
+ install -d ${D}/${libdir}
+ install -m 0755 libaticore.so ${D}/${libdir}/libaticore.so
+
+ install -d ${D}/${includedir}
+ install -m 0644 aticore.h ${D}/${includedir}/aticore.h
+
+ cd ${D}/${libdir}/
+ ln -s libaticore.so libaticore.so.1
+ ln -s libaticore.so libaticore.so.1.0
+}
+
+do_stage() {
+ install -m 0644 aticore.h ${STAGING_INCDIR}
+ oe_libinstall -so libaticore ${STAGING_LIBDIR}
+}
+
diff --git a/packages/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb b/packages/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
index 26b010ca61..ef022439cd 100644
--- a/packages/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
+++ b/packages/sharp-binary-only/sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
@@ -15,12 +15,12 @@ S = "${WORKDIR}"
inherit module-base
do_install() {
- install -d ${D}/etc/pcmcia/cis
- install -d ${D}/lib/modules/${KERNEL_VERSION}/pcmcia
- install -m 0644 ${WORKDIR}/CE-AG06.dat ${D}/etc/pcmcia/cis/
- install -m 0644 ${WORKDIR}/sharpzdc.conf ${D}/etc/pcmcia/
- install -m 0755 ${WORKDIR}/sharpzdc ${D}/etc/pcmcia/
- install -m 0644 ${MACHINE}/sharpzdc_cs.o ${D}/lib/modules/${KERNEL_VERSION}/pcmcia/
+ install -d ${D}/${sysconfdir}/pcmcia/cis
+ install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia
+ install -m 0644 ${WORKDIR}/CE-AG06.dat ${D}/${sysconfdir}/pcmcia/cis/
+ install -m 0644 ${WORKDIR}/sharpzdc.conf ${D}/${sysconfdir}/pcmcia/
+ install -m 0755 ${WORKDIR}/sharpzdc ${D}/${sysconfdir}/pcmcia/
+ install -m 0644 ${MACHINE}/sharpzdc_cs.o ${D}/${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
}
FILES_${PN} = "/"
diff --git a/packages/sharp-binary-only/sharp-sdmmc-support_2.4.18-rmk7-pxa3-embedix.bb b/packages/sharp-binary-only/sharp-sdmmc-support_2.4.18-rmk7-pxa3-embedix.bb
index 7b9492faf7..c029795e02 100644
--- a/packages/sharp-binary-only/sharp-sdmmc-support_2.4.18-rmk7-pxa3-embedix.bb
+++ b/packages/sharp-binary-only/sharp-sdmmc-support_2.4.18-rmk7-pxa3-embedix.bb
@@ -18,12 +18,12 @@ INITSCRIPT_NAME = "sd"
INITSCRIPT_PARAMS = "start 39 S . stop 96 0 1 6 ."
do_install() {
- install -d ${D}/etc/init.d ${D}/sbin
- install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/block/
- install -m 0755 ${WORKDIR}/sdmgr ${D}/sbin/
+ install -d ${D}/${sysconfdir}/init.d ${D}/${base_sbindir}
+ install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/block/
+ install -m 0755 ${WORKDIR}/sdmgr ${D}/${base_sbindir}/
install -m 0755 ${WORKDIR}/sdcontrol ${D}/${sysconfdir}
- install -m 0755 ${WORKDIR}/sd ${D}/etc/init.d/
- install -m 0644 ${MACHINE}/sharp_mmcsd_m.o ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/block/
+ install -m 0755 ${WORKDIR}/sd ${D}/${sysconfdir}/init.d/
+ install -m 0644 ${MACHINE}/sharp_mmcsd_m.o ${D}/${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/block/
}
FILES_${PN} = "/"