aboutsummaryrefslogtreecommitdiffstats
path: root/packages/shfs
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 10:40:08 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 10:40:08 +0000
commit1bb521fd96e47c6437bda16cf922d897a171fc14 (patch)
tree6579b2df48f9bf5f48192b377dd81d1a41c9f85b /packages/shfs
parent52da54beb1ebd89a0fcfdfea8247b357128e8e97 (diff)
downloadopenembedded-1bb521fd96e47c6437bda16cf922d897a171fc14.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/20 04:02:25-05:00 handhelds.org!kergoth automake 1.9.x build fixes: ice, libsm, libxcursor, libxfixes, libxft, libxss, xcomposite, xdamage, xpm, xt, xtst. 2005/01/20 04:00:34-05:00 handhelds.org!kergoth Disable PARALLEL_MAKE in opie-tinykate. 2005/01/20 03:58:05-05:00 handhelds.org!kergoth rosetta: inherit gettext and depend on virtual/libintl. 2005/01/20 03:57:40-05:00 handhelds.org!kergoth A few STAGING_KERNEL_DIR and PACKAGE_ARCH fixes for multimachine builds. 2005/01/20 03:53:46-05:00 handhelds.org!kergoth tosa.conf: don't bother installing the real modutils.. the busybox modutils is fine. 2005/01/20 03:52:08-05:00 handhelds.org!kergoth wireless-tools: Apply patch to stop poking into the kernel headers where it shouldnt be, clean things up, use the local wireless.h instead of the kernel's, and split out into more granular ipks. 2005/01/20 03:49:43-05:00 handhelds.org!kergoth Patch ipkg to fix a bug when built for relatively recent uclibc. BKrev: 41ef8a88apPGTS6jqkoO28j6FLNtjg
Diffstat (limited to 'packages/shfs')
-rw-r--r--packages/shfs/shfs-utils_0.35.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/shfs/shfs-utils_0.35.bb b/packages/shfs/shfs-utils_0.35.bb
index e69de29bb2..4af52f2973 100644
--- a/packages/shfs/shfs-utils_0.35.bb
+++ b/packages/shfs/shfs-utils_0.35.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "A simple and easy to use Linux kernel (2.4+) module which allows you to mount remote filesystems using plain shell (ssh/rsh) connection. \
+It supports some nice features like number of different caches for access speedup, target system optimisations, etc."
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "shfs-modules (${PV})"
+DEPENDS = "virtual/kernel"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/shfs/shfs-${PV}.tar.gz"
+S = "${WORKDIR}/shfs-${PV}/shfsmount"
+
+KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
+KV = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')[:3]}"
+
+CFLAGS_append=' -DVERSION=\\"${KERNEL_VERSION}\\" -DSHFS_VERSION=\\"${PV}\\" -I../shfs/Linux-${KV}'
+
+do_compile() {
+ oe_runmake LINKER="${CC}"
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 shfsmount shfsumount ${D}/${bindir}
+}