aboutsummaryrefslogtreecommitdiffstats
path: root/packages/shopper
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/shopper
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/shopper')
-rw-r--r--packages/shopper/shopper_1.2.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/packages/shopper/shopper_1.2.1.bb b/packages/shopper/shopper_1.2.1.bb
index e69de29bb2..66cdf197f2 100644
--- a/packages/shopper/shopper_1.2.1.bb
+++ b/packages/shopper/shopper_1.2.1.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Shopping list manager"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+MAINTAINER = "David Greaves <arbor@users.sourceforge.net>"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/zaurus-shopper/Shopper-${PV}.tar.gz \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/Shopper"
+
+inherit palmtop
+
+QMAKE_PROFILES = "Shopper.pro"
+
+pkg_preinst() {
+ cp /root/Applications/ShoppingListQt/shoppinglist.xml /root/Applications/ShoppingListQt/shoppinglist.xml.safe 2>/dev/null
+ true
+}
+
+pkg_postinst() {
+ /opt/QtPalmtop/bin/qcop QPE/System "linkChanged(QString)" 2>/dev/null
+ if [ -n "$D" ]; then false; fi
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/help/html
+ install -m 0755 ${S}/Shopper ${D}${palmtopdir}/bin/
+ install -m 0644 ${S}/Shopper.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 ${S}/Shopper.png ${D}${palmtopdir}/pics/
+ install -m 0644 ${S}/Shopper.html ${D}${palmtopdir}/help/html/
+# BAD BAD BAD: packages never install into home directories. ever. --CL
+# install -m 0644 ${S}/shoppinglist.xml ${D}root/Applications/ShoppingListQt/shoppinglist.xml.new
+}