aboutsummaryrefslogtreecommitdiffstats
path: root/packages/simh
diff options
context:
space:
mode:
authorMichael Krelin <hacker@klever.net>2007-06-17 19:29:08 +0000
committerMichael Krelin <hacker@klever.net>2007-06-17 19:29:08 +0000
commitf881476e2a4f25aa2cc819885950b05f3a0c6784 (patch)
treeace792898bc4db5b761f899ff40bd1c66155257a /packages/simh
parent3bc99f3297ebf23dffd56f5afbe178a8d4a2084e (diff)
downloadopenembedded-f881476e2a4f25aa2cc819885950b05f3a0c6784.tar.gz
packages/simh: added a The Computer History Simulation Project package.
it's nice to have the power of pdp-11 in your pocket, isn't it?
Diffstat (limited to 'packages/simh')
-rw-r--r--packages/simh/.mtn2git_empty0
-rw-r--r--packages/simh/files/.mtn2git_empty0
-rw-r--r--packages/simh/files/makefile.patch36
-rw-r--r--packages/simh/simh_3.7-1.bb47
4 files changed, 83 insertions, 0 deletions
diff --git a/packages/simh/.mtn2git_empty b/packages/simh/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/simh/.mtn2git_empty
diff --git a/packages/simh/files/.mtn2git_empty b/packages/simh/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/simh/files/.mtn2git_empty
diff --git a/packages/simh/files/makefile.patch b/packages/simh/files/makefile.patch
new file mode 100644
index 0000000000..dce99d81f5
--- /dev/null
+++ b/packages/simh/files/makefile.patch
@@ -0,0 +1,36 @@
+diff --git a/makefile b/makefile
+index 4973273..10cc672 100644
+--- a/makefile
++++ b/makefile
+@@ -10,19 +10,15 @@ OS_CCDEFS = -lsocket -lnsl -lpthread -D_GNU_SOURCE
+ else
+ OS_CCDEFS = -D_GNU_SOURCE
+ endif
+-ifeq ($(OSTYPE),macos)
+-CC = gcc -std=c99 -O2 -U__STRICT_ANSI__ -g -lm -lrt $(OS_CCDEFS) -I .
+-else
+-CC = gcc -std=c99 -O2 -U__STRICT_ANSI__ -g -lm $(OS_CCDEFS) -I .
+-endif
++CC := ${CC} -std=c99 -U__STRICT_ANSI__ -lm -lrt $(OS_CCDEFS) -I .
+ ifeq ($(USE_NETWORK),)
+ else
+-NETWORK_OPT = -DUSE_NETWORK -isystem /usr/local/include /usr/local/lib/libpcap.a
++NETWORK_OPT = -DUSE_NETWORK -DNEED_PCAP_SENDPACKET -lpcap
+ endif
+ else
+ #Win32 Environments
+ LDFLAGS = -lm -lwsock32 -lwinmm
+-CC = gcc -std=c99 -U__STRICT_ANSI__ -O0 -I.
++CC := ${CC} -std=c99 -U__STRICT_ANSI__ -O0 -I.
+ EXE = .exe
+ ifeq ($(USE_NETWORK),)
+ else
+@@ -30,6 +26,8 @@ NETWORK_OPT = -DUSE_NETWORK -lwpcap -lpacket
+ endif
+ endif
+
++CC := ${CC} ${CPPFLAGS} ${CFLAGS}
++
+ #
+ # Common Libraries
+ #
diff --git a/packages/simh/simh_3.7-1.bb b/packages/simh/simh_3.7-1.bb
new file mode 100644
index 0000000000..6240fed4f9
--- /dev/null
+++ b/packages/simh/simh_3.7-1.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "The Computer History Simulation Project"
+HOMEPAGE = "http://simh.trailing-edge.com/"
+SECTION = "console/misc"
+LICENSE = "as-is"
+DEPENDS = "libpcap"
+PR = "r0"
+
+URIPV = "${@bb.data.getVar('PV',d,1).replace('.','')}"
+SRC_URI = "http://simh.trailing-edge.com/sources/simhv${URIPV}.zip \
+ file://makefile.patch;patch=1"
+S = "${WORKDIR}/${PN}-${PV}"
+
+python do_unpack() {
+ import os
+ os.mkdir(bb.data.getVar('S',d,1))
+ tmp = bb.data.createCopy(d)
+ bb.data.setVar('WORKDIR',bb.data.getVar('S',d,1),tmp)
+ bb.build.exec_func('base_do_unpack', tmp)
+}
+
+do_compile() {
+ mkdir BIN || true
+ make USE_NETWORK=1 || die "make failed"
+}
+
+do_install() {
+ install -d "${D}${bindir}"
+ cd "${S}/BIN"
+ for bin in * ; do
+ install -m 0755 "$bin" "${D}${bindir}/${PN}-${bin}"
+ done
+ install -d "${D}${datadir}/${PN}"
+ install -m 0644 ${S}/VAX/*.bin "${D}${datadir}/${PN}/"
+}
+
+PACKAGES_DYNAMIC = "simh-*"
+
+populate_packages_prepend() {
+ do_split_packages( d, bb.data.getVar('bindir',d,1), '^simh-(.*)$',
+ output_pattern='simh-%s',
+ description='SIMH for %s',
+ prepend=True, extra_depends='')
+}
+
+PACKAGES += "${PN}-vaxbin"
+
+FILES_${PN}-vaxbin = "${datadir}/${PN}"