aboutsummaryrefslogtreecommitdiffstats
path: root/packages/snes9x
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 18:44:34 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 18:44:34 +0000
commitcea573b7ab71cabae28020c7d3a11ee90b03d901 (patch)
treee0c8053c806236d0ed5d24e845b60e6b9fa42c3a /packages/snes9x
parentb53bf6999ed1feedd9d79f1c99b63ddc811b39af (diff)
downloadopenembedded-cea573b7ab71cabae28020c7d3a11ee90b03d901.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/31 10:44:33-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2004/12/31 10:44:17-08:00 (none)!ggilbert Licensing additions 2004/12/31 18:41:30+01:00 (none)!br1 added stunnel init script and configuration file BKrev: 41d59e12wekLBFs_VrpoqSRgkooaYw
Diffstat (limited to 'packages/snes9x')
-rw-r--r--packages/snes9x/snes9x-sdl-qpe_1.39.bb23
-rw-r--r--packages/snes9x/snes9x_1.43-WIP1.bb26
2 files changed, 49 insertions, 0 deletions
diff --git a/packages/snes9x/snes9x-sdl-qpe_1.39.bb b/packages/snes9x/snes9x-sdl-qpe_1.39.bb
index e69de29bb2..416b35b2a5 100644
--- a/packages/snes9x/snes9x-sdl-qpe_1.39.bb
+++ b/packages/snes9x/snes9x-sdl-qpe_1.39.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Super Nintendo Emulator based on SDL, QtE Palmtop Environments Edition"
+SECTION = "opie/games"
+PRIORITY = "optional"
+DEPENDS = "libsdl-qpe"
+PR = "r1"
+LICENSE = "snes9x"
+SRC_URI = "http://www.vanille.de/mirror/snes9x-sdl-${PV}.tar.bz2 \
+ file://compile.patch;patch=1"
+S = "${WORKDIR}/snes9x-sdl-${PV}"
+
+FILES_${PN} = "${palmtopdir}/bin/snes9x"
+
+do_compile() {
+ oe_runmake CC="${CC}" CCC="${CXX}" \
+ INCLUDES="-I${STAGING_INCDIR} `sdl-config --cflags`" \
+ LDLIBS="`sdl-config --libs` -Wl,-rpath-link,${STAGING_LIBDIR}"
+}
+
+do_install() {
+ install -d ${D}/${palmtopdir}/bin/
+ install -m 0755 snes9x ${D}/${palmtopdir}/bin/snes9x
+}
+
diff --git a/packages/snes9x/snes9x_1.43-WIP1.bb b/packages/snes9x/snes9x_1.43-WIP1.bb
index e69de29bb2..b30dccecee 100644
--- a/packages/snes9x/snes9x_1.43-WIP1.bb
+++ b/packages/snes9x/snes9x_1.43-WIP1.bb
@@ -0,0 +1,26 @@
+SECTION = "x11/games"
+PR = "r3"
+LICENSE = "snes9x"
+DEPENDS = "libxxf86dga libxxf86vm"
+DEPENDS_append_i686 = " nasm-native"
+RDEPENDS_epia = "kernel-module-joydev"
+
+SRC_URI = "http://www.lysator.liu.se/snes9x/1.43-WIP1/snes9x-1.43-WIP1-src.tar.gz \
+ file://makefile.patch;patch=1;pnum=2 \
+ file://private.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/snes9x-1.43-dev-src/snes9x"
+
+inherit autotools
+
+export OECFLAGS="${CFLAGS}"
+export OELDFLAGS="${LDFLAGS}"
+
+do_configure() {
+ oe_runconf
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install snes9x ${D}${bindir}
+}