aboutsummaryrefslogtreecommitdiffstats
path: root/packages/softfan
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 07:40:09 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 07:40:09 +0000
commit7d6006735f2de129c026f9ff3d55f854591124df (patch)
tree3d220c42a2367e6730a3ea24bacf919aa4991bfc /packages/softfan
parent49275ccd3ebfa3ae13b2a6b49402c09cd88cc719 (diff)
downloadopenembedded-7d6006735f2de129c026f9ff3d55f854591124df.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/30 23:33:57-08:00 (none)!ggilbert Adding licenses BKrev: 41d50259A1gWI8c_Qj68LM4jway6jw
Diffstat (limited to 'packages/softfan')
-rw-r--r--packages/softfan/softfan_0.10.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/softfan/softfan_0.10.bb b/packages/softfan/softfan_0.10.bb
index e69de29bb2..34f00f01c9 100644
--- a/packages/softfan/softfan_0.10.bb
+++ b/packages/softfan/softfan_0.10.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Fan controller for fans attached to parallel port"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SRC_URI = "http://joshuawise.com/code/softfan/softfan-${PV}.tar.gz"
+S = "${WORKDIR}/softfan-${PV}"
+
+FILES_${PN} = "/sbin/softfan"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o softfan softfan.c
+}
+
+do_install() {
+ install -d ${D}/sbin
+ install -m 0755 softfan ${D}/sbin/softfan
+}