aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sox
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2007-03-21 13:37:00 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2007-03-21 13:37:00 +0000
commit9ede5dc2c95dbe53ec5a00c0e22837263673e172 (patch)
tree61173ad3613f67fc1f1a86deb0466a0d99c21f9a /packages/sox
parent76eb025c76dfc754aa08cd2063f22938a72caf05 (diff)
downloadopenembedded-9ede5dc2c95dbe53ec5a00c0e22837263673e172.tar.gz
sox: Add updated sox and new package sox-native
Diffstat (limited to 'packages/sox')
-rw-r--r--packages/sox/sox-native_13.0.0.bb19
-rw-r--r--packages/sox/sox_12.17.5.bb2
-rw-r--r--packages/sox/sox_13.0.0.bb18
3 files changed, 38 insertions, 1 deletions
diff --git a/packages/sox/sox-native_13.0.0.bb b/packages/sox/sox-native_13.0.0.bb
new file mode 100644
index 0000000000..9b4dd29433
--- /dev/null
+++ b/packages/sox/sox-native_13.0.0.bb
@@ -0,0 +1,19 @@
+include sox_${PV}.bb
+
+S = "${WORKDIR}/sox-${PV}"
+
+inherit native
+
+do_patch() {
+ true
+}
+
+do_stage() {
+ make bindir="${STAGING_BINDIR}" libdir="${STAGING_LIBDIR}" mandir="${STAGING_DIR}/${HOST_SYS}/man" includedir="${STAGING_INCDIR}" install
+ rm ${STAGING_BINDIR}/rec
+ ln -s ${STAGING_BINDIR}/play ${STAGING_BINDIR}/rec
+}
+
+do_install() {
+ true
+}
diff --git a/packages/sox/sox_12.17.5.bb b/packages/sox/sox_12.17.5.bb
index 6c70eaad7b..a3cd84e726 100644
--- a/packages/sox/sox_12.17.5.bb
+++ b/packages/sox/sox_12.17.5.bb
@@ -4,7 +4,7 @@
DESCRIPTION="SoX is the Swiss Army knife of sound processing tools. \
It converts audio files among various standard audio file formats \
-and can apply different effects and filters to the audio data."
+and can apply different effects and filters to the audio data."
LICENSE="GPL"
HOMEPAGE="http://sox.sourceforge.net"
diff --git a/packages/sox/sox_13.0.0.bb b/packages/sox/sox_13.0.0.bb
new file mode 100644
index 0000000000..f5c554799d
--- /dev/null
+++ b/packages/sox/sox_13.0.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION="SoX is the Swiss Army knife of sound processing tools. \
+It converts audio files among various standard audio file formats \
+and can apply different effects and filters to the audio data."
+HOMEPAGE = "http://sox.sourceforge.net"
+SECTION = "audio"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sox/sox-${PV}.tar.gz \
+ file://src-Makefile.am.patch;patch=1"
+
+inherit autotools
+
+do_install() {
+ make bindir="${D}${bindir}" libdir="${D}${libdir}" mandir="${D}/${mandir}" includedir="${D}${includedir}" install
+ rm ${D}${bindir}/rec
+ ln -s /usr/bin/play ${D}${bindir}/rec
+}